Hi, brave is telling me that it could not access the secure storage and sync is not active, does anyone know how to solve it?
The message with google translation is that:
“Brave was unable to access your operating system’s secure storage. This is the storage used to protect data such as passwords and cookies; it is also required for Brave Sync to connect your browser profile between different devices. This means Brave Sync is not running. To resolve this issue, see the Brave Sync troubleshooting guide.”

1 Like

I have the same problem

Thank you for posting. I’m having the same issue. Windows 10 Pro. Thinking to just uninstall then reinstall to see if that resolve it

1 Like

but i will lose everything right?

@LUCIANOAYB Don’t do it that way. First thing I want to do is ask what OS you’re using and which version of Brave you’re on?

Second thing I’m going to do is tag @Mattches as he’s generally helping with this. But the other thing is to loop in @jsecretan because he mentioned yesterday to tag him on people having this issue.

That said, if you can be a bit patient and talk to people from Brave, they can help you with more official solutions and try to figure out what’s going on so it can be resolved for others.

If, for any reason, you’re impatient and can’t wait to work with Brave on it, then people said they just went to brave://sync-internals and hit Disabled Sync (Clear Data) to remove the device from the sync chain and then they added to new sync chain. This is a workaround and not a solution.

If you actually uninstalled Brave, yes, you could lose at least the BAT you have in your browser. If you just strictly updated it, no. Overall, you never want to uninstall unless absolutely necessary.

We’re working on getting information on this error message up on the Help Center presently. But put simply, Brave Sync is trying to access — as stated in the message — your safe storage data, which it at this time does not have access to. This typically happens when [system] login credentials are changed, permissions are changed or sometimes after a system update.

For users on macOS encountering this
You should see a notification prompting you to enter your password to the keychain, as shown below:

If not, you can still grant access manually by:

  1. Open the Keychain Access app
  2. Choose Login under the Default keychains section on the left
  3. Find Brave Safe Storage
  4. Click on Access control and check to see if Brave Browser is listed here:

    If it is not, click the + button and add it, then Save changes (you’ll have to re-enter your password)

For Linux users encountering this
As with macOS, Linux uses should see a similar prompt:

If not, you can manually grant access by:

  1. Open the Passwords and Keys app
  2. Ensure that the icon is unlocked (click Unlock and enter your password to unlock)
  3. Check to see if Brave Safe Storage is there — if not, please click the + button to add it.

For Windows users encountering this
Unfortunately there is no quick fix for this on Windows — again, this typically only happens when you make changes to your system user name/password credentials. Typically, only a user with the same logon credential as the user who encrypted
the data can decrypt the data. In addition, the encryption and decryption
usually must be done on the same computer.

As such, we recommend resetting Sync and re-syncing your devices. You can do this by going to brave://sync-internals and using the Disable Sync (Clear data) option.

cc @Saoiray @Chocoholic @SaltyBanana for visibility


I have this exact problem on a Mac - but Brave Browser is already available in Keychain Access. “Ask for Keychain Password” was not checked, so I changed that and saved changes. No improvements. I removed and re-added Brave Browser, no changes.

1 Like

I have the same problem. I am using Brave in a Linux system:

Fedora Linux 36 (Xfce) x86_64
Kernel: 5.19.8-200.fc36.x86_64
DE: Xfce 4.16
WM: Xfwm4

Installed from the official Brave repo at


I am also being logged out of all my accounts, like it’s cleaning cookies every time I close the browser. And yes, I’ve made sure that I have the clear cookies setting disabled:


EDIT: Per the instructions above, I checked the passwords and keys app and Brave is already there



I tried this solution on OSX, but it doesn’t work for me, even after a restart. Unfortunately I still have the same error message.

What exact OS version are you using @Smolk ?

I’m on Fedora 36 and running into the same problem. Brave is in password and keys app but the problem still happens.

For Linux users: If you get a message that the sync service could not be started, there is a command line option to the brave-browser command you can try to see if it makes any difference:

--password-store=X where X is one of kwallet, kwallet5, gnome, gnome-keyring, gnome-libsecret, basic.

For example: If you change desktop environment from gnome to KDE on the same machine, you may have to use --password-store=gnome to force brave to use the gnome keyring. And vice versa with --password-store=kwallet.

Another way to change brave behaviour is this respect is to change the environment variable DESKTOP_SESSION to e.g. gnome, to have the same effect as the above command line option.

I managed to solve my problem by setting the DESKTOP_SESSION variable to gnome after switching from gnome to wayfire.

This wiki is also really good (thanks Arch!):

I had this issue too. Tried all the steps above, no success. I migrated my OSX user profile from my other Mac, then changed my login credentials for security reasons. So I know what caused the problem, but so far no fix for it. I could try setting up a new user, but that would necessitate re-establishing all other settings and preferences (very time consuming).

@Mattches, is there an update for Mac users for whom your fix didn’t work?

It’s been a while since I’ve looked at this issue and sorry for those who are still encountering this. @alvanx @nickbe to be clear, you are both getting the same error when trying to use Sync (shown below)? Can you please reconfirm the exact behavior for this issue?

Thank you.

@Mattches, I retraced the steps in your workaround above. I don’t get that keychain prompt, and Brave hasn’t been notifying me that sync doesn’t work, but I still get the same error message at brave://settings/braveSync/setup (sorry, this is all in German):

My phone still lists this device as a part of the sync chain.

The keychain interface for “Brave Safe Storage” was already listing Brave when I first checked, and looks exactly as it does in your screenshot:

This is on Ventura.

To be clear, you do have a device still part of the Sync chain right now right (your phone)? If so, please try the following:

  1. On your macOS installation, please go to brave://sync-internals
  2. On this page, select Disable Sync (Clear data)
  3. Open the Sync page again and attempt to setup Sync again on the device, using the code from your phone that is still connected to the Sync chain.

Please let me know if this works for your. Thank you

That worked! Thanks a lot!

1 Like