Sync not working (Android)

I have been using brave on my mobile for quite a while now. Recently I got myself a new phone and started porting things over. Both are on android 10. I did a search online and noted that there is no manual export bookmark function available and the only way get the bookmarks out is to sync from my existing mobile to my PC, then from my PC to the new android device.

So i started the sync chain between my mobile and my PC but nothing is working. The PC is not getting any bookmark sync from my mobile. How do i make this sync work? Or is there any other way to get the bookmarks out from my existing phoneto the new phone?

1 Like

@viperc,
Can I ask how many bookmarks you’re transferring? It can sometimes take a bit for a large number of bookmarks (ex.1000+) to Sync, especially if you’re syncing other data along with it.

Additionally, can you confirm that you’ve closed one or both of the browsers after adding them to the Sync chain? We have had issues in the past where the Sync action wouldn’t start until one to both browsers on the chain had been relaunched.

@Mattches thanks for the input. I have around 100 odd bookmarks on my phone. I have tried closing and relaunching both the bowser’s in my pc and phone but the sync did not start. I have also tried removing all devices from the sync chain and creating a new one but didn’t help.

For the closing of browser, does the opened tabs need to be closed as well? I only closed all opened app from android.

@viperc,
On your PC, can you launch Brave and go to brave://sync-internals and take a screenshot of this page for me and share it in this thread? This will tell us a bit more information about what the Sync process is trying to do.

@Mattches Attached the screenshot below. I tested between my PC and new phone. Only 2 bookmarks on the PC. Nothing in the new phone. But it’s still not syncing.

@Mattches anything you can see from the screenshot?

@viperc,
So sorry for the late response – can I actually ask to see a screenshot of the same page but on the Android side? At a glance, everything looks as though it should be working without issue.

@Mattches have been holding back fully migrating to my new phone. Please let me know there is a fix or something I did wrongly. Lol. Thanks.

1 Like

Have you tried “auto sync data” in android settings?

link

Sync v2 on Android respects the system-wide option “Automatically sync data”, so if you found that Brave Sync v2 does not work on your Android device, you should ensure that system option is in the position on. The location of that option depends on device manufacturer, but you may find it in:

  • System settings --> Accounts --> Automatically Sync Data
  • System settings --> Accounts and backup --> Accounts --> Auto Sync Data
  • System settings --> Cloud and accounts --> Accounts --> Auto Sync Data

In order to sync v2 work on Android it is required to turn that option on.