Sync Just Doesnt Work / also not able to leave a sync chain

Description of the issue:
Sync chain just doesnt work on desktop, when I join a chain it lets me set my preffered sync settings and then when I close and re-open the settings it has removed all my selections. as well leaving a chain does not work, I have attempted multiple times on several profiles with different chains and none of them are able to leave. I have an android device I would like to sync my data from my desktop to because you cant import the data from chrome on mobile.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Make new profile

Create or join chain

Set any settings sync settings

Close and reopen settings

Sync settings are reset

Try to leave chain
Brave Version(See the About Brave page in the main menu):
Version 1.27.111 Chromium: 92.0.4515.131 (Official Build) unknown (64-bit)
Type of devices currently running on the Sync chain in question:
Operating System: Arch Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.13.13-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 5700 XT
Additional Information:

1 Like

same problem for me …

Thanks for reaching out. Just to confirm, when you select Leave sync chain what happens exactly? Additionally, can you share a screenshot of your brave://sync-internals page here in this thread? Ideally from both your desktop device and Android device – this will let us peek under the hood a bit and see what may be going on.

When I leave the sync chain, it just takes me back to the main settings page, then when I return to the sync settings (manage your synced devices) it still has the same sync code, and qr and the sync settings are all set to off. the same happens when changing any other sync settings and no devices show under the device list. Looking at that sync settings page shows the following on my devices. I also have a recording of the issue I am experiencing that I can PM if you would like

1 Like

@xanthirus currently it is impossible to leave the chain when device is offline or there are some errors from the server. The connection is required to inform other devices that the current device now is leaving chain.

I see there is SYNC_SERVER_ERROR HTTP, but I cannot the exact code. Could you please scroll a bit to the right in a right side of your window or look on Traffic Log side for the exact HTTP error code value?

As an emergency way you can press Disable Sync (Clear Data) button on brave://sync-internals page.

Hey, I had the same issue.

After doing it, everything works properly.


I tried using Disable Sync (Clear Data) and I rejoined and I am still receiving the same error message here is what I have for the traffic log.