Swisscows as default search engine is not possible to use

I couldn’t add Swisscows as a default search engine in Brave 1.40.105 my OS is Linux. I have chosen Swisscows as the default search engine and it should be possible to write a subject in the address bar. It ends with this result: “Error 404: Page not found” when I do so. I have opened a new tab and hoped to see Swisscows so I can search with that search engine. But every time, the Brave page opens.
I have clicked: Settings, Search engine, Manage search engines and site search but it always ends with a 404 page when I write this URL down : “https://www.swisscows.com/search?q=%s”. If I only write swisscows.com do the Swisscows page open.
What is there to do to make Swisscows page function with Brave?
Disappointed Brave user

Hi and welcome to the community. Did you try this from Swisscows article How to use Swisscows as default search?

Thank you so much
Hafsytan