Swap transaction stuck

I am trying to make a swap on the Solana Network.
The Transaction said processing, but there is no results on the Explorer page. I tried to resubmit, now I have 2 stuck transactions. How do I cancel a swap or clear the Cache to get this working again.

Please only post Brave Wallet inquiries in this category – visit the Brave Rewards category for all related rewards issues.

The Brave Team will never ask you for your recovery phrase or private key.

Description of the issue: Stuck Swap transactions. Submitted Block not found on Explorer

Is the issue occurring on a specific network? Solana

What operating system are you using? Windows

Brave Version (check About Brave): v1.61.101
Additional Information:

Hello! Could you provide a screenshot of what you are seeing in your Transaction Details? Thanks!

Did you ever get a response that could help you out DingGuy? Asking, case same exact thing happened to me yesterday and I also have two transactions that have done same thing. I figured it was a PYTH network issue, cause both transactions are with SOL to PYTH swap using brave wallet and when I use jup.ag it won’t allow a transaction due to some kind of network error, yet my other transactions not involving PYTH have all been fine. Over 24 hours now and the two transactions are still showing submitted with the little blue circle still spinning like it’s trying to do the transaction still.

1 Like

no answer. I tried restoring the wallet, no effect.
I’m new to the Brave wallet, but not real happy that I have a wallet frozen on a day that there were a lot of trades to be made. luckily this is not a wallet I have anything more than a test amount on.

23 hours and there is no way to cancel order or clear. I tried this as well…

Unfortunately, it’s a Friday night right now, which means chances of any replies before Monday are pretty slim. You rarely see support or devs here on the weekends to help people.

I don’t use Wallet enough so I hesitate to suggest this, but could you be referring to Clear wallet transaction and nonce information that you find in Brave’s Web3 settings, which is brave://settings/web3?

Also not sure if can cancel in the hamburger menu that exists next to the amount where it shows Submitted.


I just went into my Wallet to take a look at my little tiny activity. Weirdly enough, I have something that still hasn’t gone through since June 10, 2023.

Below Transaction fee and all, it has a button to Cancel transaction. Does yours not have that?

Looks like I was able to successfully cancel the transaction.

I am a bit confused on the screenshot as well after looking at mine. None of what I see has the hamburger menu (three dots) on the right. Yet both supposedly using same 1.61.101 and Windows.

1 Like

@Dingguy and @svmgwest, I just flagged their comment (which makes it harder to see) but not sure if you’ll see via email or anything. Make sure you ignore the link and all provided by millerwest if you are able to see it. It’s a scam bot.

1 Like

mine does not have the cancel or gas fee meter below…

Screenshot 2023-12-09 144500
Tried to rest the whole wallet as well as the nonce… nothing changed

1 Like

Ok. I’ll be hoping @Evan123, @jleonard, or @onyb might be able to pop in with guidance here. Evan is Support and the other two are Wallet devs.

1 Like

I saw @jleonard reply to a couple other topics today so hoping he might be around. Otherwise I’ll tag in the other support because I am wanting to try to get eyes on this and learn how it works. So @steeven @Mattches and @Evan123, when any of you get time.

Hello! I’ve brought this up to the team and we are looking into it. Thanks!


Do you see confirmation on the Solana Explorer? It may already be finalized. I was able to resolve this by resetting the transaction information.

Please let me know. Thanks!

nothing has changed. Transactions are still stuck… the transaction is not found on explorer

I don’t know how I can Reset transactions. As mentioned in my other comments, I can’t find a way to cancel or reset anything other than the resets to the wallet, which have not helped. I have 3 transactions backed up since Friday. I aam going to have to look for another wallet to use for Solana, the market is moving and I want to make some swaps…

@DingGuy , Here is where you can reset your wallet transaction information.

@jleonard would it make sense if nothing changed when that was done? Asking as they said had done it earlier.

1 Like