Suddently cannot launch Brave (solved)

** ETA I tried again and Brave actually launched and did an update after which I was prompted to relaunch the browser. It’s working fine now.**

Description of the issue:
I opened Brave (desktop browser) today and it wouldn’t launch. It was not responding other than the icon to keep bouncing in the dock. I had to force quit.

How can this issue be reproduced?
I tried multiple times to launch the app from the dock. I even tried downloading and installing the latest version and that too failed to launch.

Actual Result (gifs and screenshots are welcome!):
Brave browser icon bounces in dock, is unresponsive in Force Quit Applications window. After a few minutes, the bouncing stops but nothing else happens.

Expected result:
I expect Brave to open normally with my previous tabs. I used Brave last week without issue.

Brave Version( check About Brave):

Additional Information:
I’m running MacOS 10.15.7 Catalina.

I’ve not updated my iMac or Brave recently. Brave was working fine last week. I read some people had issues opening Chrome. I have no issues with Chrome or any other application I’ve used recently.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.