Cannot launch brave anymore

Description of the issue:
I’ve been using brave without issue for several months but since yesterday I am no longer able to launch Brave.

Steps to Reproduce (add as many as necessary):
Hard to say as I am simply running the lastest (release) version of Brave on macOS (mojave). It seems to be happening since it autoupdated but I’ve tried downloading the beta version and that runs fine. I also used a couple of extensions (which never caused any trouble before):

Actual Result (gifs and screenshots are welcome!):
Opens an empty window which never loads anything and eventually becomes unresponsive

Expected result:
Brave launch normally

Reproduces how often:
100%

Operating System and Brave Version(See the About Brave page in the main menu):
MacOs 10.14.4, not sure about the brave version as I can’t actually launch it but I think it autoupdated yesterday so I guess latest?

Additional Information:

1 Like

Welcome, @bnjmn. I just updated Brave to the latest version in macOS Mojave 10.4.5 without issue. I doubt it’s a 10.4.4 vs. 10.4.5 issue, but one never knows.

I’d try turning off your extensions and relaunching Brave, but if you can’t get at the settings screens, try downloading the standalone installer for Brave, running that, and seeing if that fixes your issue. Here is a direct link to the standalone installer:
https://github.com/brave/brave-browser/releases/download/v0.65.118/Brave-Browser.dmg

You probably know this, but that’s a disk image, and once it downloads, you open it and drag Brave to your Applications folder. Then you open the copy in your Applications folder as you normally would. Your settings and such should be unaffected.

If that doesn’t work, there are some other possibilities we can pursue.

Hey @hnktong. Thanks for getting back to me on this one.

So I’ve already tried a few things to try and isolate the problem.
Firstly I’ve already attempted to reinstall as per your instructions without avail, same result.
I’ve also had a dig around in ~/Library/Application Support/BraveSoftware, tried renaming the brave folder to something else in order to generate a fresh one (which fixed everything but lost all my settings, sessions, bookmarks etc).
Then I tried using the Beta version and copying the contents of BraveSoftware/Brave-Browser into BraveSoftware/Brave-Browser-Beta which solved the issue issue tho it was an older version I already had installed so it autoupdated and I took the opportunity to disable all the extensions and sequentially enable each and relaunch the application. Finally I landed in the same place (crashing on launch) when enabling the The Creative Independent extension I mentioned in my original post. I’d be happy to disable that but I’m unable to disable the extension (as I can’t open Brave). It might be that though it could be coincidence as I was unable to test more than once!

Having the same problem. Have deleted and reinstalled. If I reboot the computer, it works for a short time then goes back to this blank screen.

Please advise… have had to use chrome… yuck

Wow, @bnjmn you’ve done a lot! As long as you didn’t trash your profile folder after renaming it, you should be able to restore your settings and such, but let’s try to fix your new one, first, and then go after settings restoration.

@CandidVolume, do you have the same extensions installed? Also, can you provide your OS and version (macOS 10.14.5, for example)?

EDIT BECAUSE NEW IDEA: Before trying the steps below, try resetting your session a bit by moving these out of your Profile folder, then try opening Brave:
image
BACK TO ORIGINAL POST

I didn’t see a way to install from the github for TCI extension, so using a throwaway profile in Brave Core, I installed the TCI extension from the webstore and restarted Brave. The browser appeared to work fine with that, so I added the rest one at a time and finally had a hiccup with 1Password, but that resolved after I restarted Brave (the browser still worked, but the extension couldn’t connect with the 1Password7 desktop application until I restarted Brave, then it was fine).

So it looks like on your system it must be the TCI extension since Brave barfs every time you enable it.

To disable TCI extension without Brave running, try going to ~/Library/Application Support/BraveSoftware/Brave-Browser/[[your profile name]]/Extensions and see if there’s a folder named hfpihhnbilfkcjakaeopanccjlcnnefp.
image
That’s what my system named the folder for TCI Extension twice. If you don’t have one named that, peek inside the folders that are there and for those that have an index.html file, open that with a text editor and look for the body tag and then a line including “a href=“https://thecreativeindependent.com” target=”_blank"" and that’s the one.
I made a copy of my profile folder and dragged it in there:


Drag the extension’s folder someplace else you can access it and try launching Brave. Here’s what I got when I tried opening a new tab after that:

Going to chrome://extensions shows TCI extension in the list and enabled, which is why the new tab page . Click the toggle to disable it, and the default new tab page is used.

So let’s stop there. Try that stuff and see if it fixes Brave for you.

Just as a reference, and this may be a well duh, but from the URLs and observation, it looks like the names of the extensions you listed are as follows:

  • TCI Extension: hfpihhnbilfkcjakaeopanccjlcnnefp

  • Are.na Extension: lkihjlcipnbgeokmfnpogjfflofbfhga

  • Deluge Siphon: gabdloknkpdefdpkkibplcfnkngbidim

  • Pocket: niloccemoadcdkdjlinkgdfekeahmflj

  • 1Password: aomjjhallfgjeglblehebfpbcfeobpgk

I mis-typed, there. As long as you didn’t trash your renamed Brave Software or Brave Browser folder (unclear which one), we should be able to get your settings back. The easiest way would be to open Brave, create a new person using the person manager, identify the profile folder after quitting Brave, copy the contents of your profile folder from the renamed Brave folder into the new one you just made (after fixing it the same way we wind up fixing Brave), and then opening Brave. Clear as mud? This was just a quick summary, and we can wallow through the details once we get Brave working.