Spell check not available for selected country

Description of the issue: Spell check not available for selected country

Steps to Reproduce (add as many as necessary):

  1. Open settings
  2. Open advanced settings
  3. Add language “German (Germany)”.
  4. Try to enable spell checking for “German (Germany)”.

Actual Result:

Expected result: Spell checker should also be enabled for German (Germany)

Reproduces how often: Always

Brave Version(about:brave): Version 0.55.20 Chromium: 70.0.3538.67 (Offizieller Build) (64-Bit)

Reproducible on current live release (yes/no): yes

Additional Information:
If you have selected “German (Germany)”, i.e. the language followed by the country (here Germany), the spell checker cannot be activated.

I had the problem to select German (Germany) first. So I couldn’t activate the switch in the settings.

After selecting “German” (which by the way is completely sufficient, you don’t need the extension “Germany”) the spellchecker also worked.

cc @sriram @Mattches in case they know anything about this. :slightly_smiling_face:

This is still not available. You can track this issue which should implement spell check for all languages that are available in b-c