(Mac) Language/Spell-check - missing options

Description of the issue:
Brave on Mac seems to lack language/spell-check options compared to Windows.

On Mac when I add more languages I cannot check option for Brave to apply it for its UI. Then in Spell-check section I have only ON/OFF toggle, however on Windows all languages from the list get their own toggle, so you can basically switch on/off spell-checking for all languages.

I am attaching screenshots:
Windows


Mac

On Mac the spell-checking is behaving funny too, it seems it is not working properly, when I add a language it is still spell-checking only English and when I move other language to the top it seems to turn off it as a whole and after restarting Brave (via cmd+Q) it seems to somehow work half way, some words in English and other language(s) seem to get marked as incorrect and some not (English and custom language included).

What’s more, on Win all the language spell-checking (adding languages and turning on/off spell-checking) seems to apply changes instantly, while as I mentioned on Mac it seems it is not applying them correctly.

Steps to Reproduce:
Add languages, turn on spell-checking, try typing,…

Actual Result (gifs and screenshots are welcome!):
Spell-checking not working or seemingly partially working (description above)

Expected result:
Spell-checking working for multiple languages simultaneously (like on Win)

Reproduces how often:
Always

Operating System and Brave Version:
OS X 10.14.5 (Mojave, last stable version)
Brave 0.65.118

Shall I report this elsewhere? Any suggestions?

This topic was automatically closed after 30 days. New replies are no longer allowed.

@rackmountedweasel,
I’m actually not entirely sure what the situation here is but I did learn some things about spellcheck. First, I didn’t see any options at all to toggle Spellcheck on/off for specific languages until I added (specifically) the English (United Kingdom) language. That option then appeared in the Use spell check for section.

It appears that only certain options are available in this section although I’m not entirely sure why. I’m digging into this further, but for now, will you test by adding (specifically) the English (United Kingdom) Language and seeing if this option/toggle is then displayed?

@Mattches

English (UK) added, no change, still no specific languages.

This is happening on Mac only, on Windows, it is works as intended, same as it worked in Chrome, where under the Spell check option I get additional “Use spell check for” with a list of languages where each of the languages is togglable, so I can choose which language(s) I want the spell check being used for.

I am using the latest stable Brave release 0.67.125, latest OSX release as well.

Weirdly enough, Chrome is changing UI of the settings, it starts to use similar view as Brave and what’s more, the language and spell-check section is now the same as in the Brave, no togglable spell-check for particular languages only a general toggle.

I don’t know if anything changed, but I tested writing a post on a forum in the latest Chrome and Brave (still on Mac) and both work exactly the same, I wrote 3 sentences, each in the different language and in both cases spell-check switched between first two and kind of failed with the third one. On Windows, it works perfectly, so I think Mac or Mac version of Chrome is the problem, but I don’t we can do anything about it.

But now I noticed a different thing not working, website translation, I am not offered the webpage to be translated (whether for the website having an unlisted language in the settings or one with the checked option to offer the translation)…

@rackmountedweasel,
Thanks for the update and apologies for the lack of response – threads sometimes get lost in the shuffle.

RE: web translation – this functionality is already in both Nightly and Dev builds and is moving through the Release pipeline.

Thank you and I get it now, thank you for stopping by and for the news regarding the translations, that is indeed a great news.

1 Like