"Sorry we're having trouble playing this video" on a particular page, on Facebook


Description of the issue:
There’s a particular page on Facebook named as LaLiga. Every time I click on any video from their page, it shows that ''sorry we’re having trouble playing this video, Learn more" before showing that it’s actually gonna start for a few milliseconds. It doesn’t matter the length of the video, or whether it’s a live video or not. Even when i move my cursor to the videos it shows the same error, when they are supposed to show a small preview of that video. It’s been going on for really a long time.

How can this issue be reproduced?

  1. Go to facebook.
  2. Go to the page named, “LaLiga”
  3. Go to the video section
  4. Play any video or, move your cursor onto any one of the videos.

Expected result:
The videos are supposed to play normally as it does on rest of facebook.

Brave Version( check About Brave):
Version 1.24.84 Chromium: 90.0.4430.93 (Official Build) (64-bit)

Additional Information:
This error only occurs on that particular page only. No where else. It works fine on Microsoft Edge browser.
I have tried everything that i know of (clear browsing data, switching off the shields, clearing cache, resetting the site permissions, going back to default settings, reinstalling Brave, tried out Brave Beta), but this error still persists.

After trying out all these, I am thinking of something which might be a reason for this issue. This LaLiga page is broadcasting live football matches in South Asia through Facebook with Broadcasting rights. Now probably somewhere along the line, Brave browser isn’t compatible with the rights.

Hello @kabbir86

go to brave://settings/extensions and make sure to enable widevine

hope that help and have a nice day :slight_smile:

Sorry that i forgot to mention. I actually tried that out and it doesn’t make any difference.

it’s ok do not be sorry
let me ask @Mattches from the team to help you with that as i do not have any other idea that you already did
plus i got the same behaviors as you do for this specific page

and have a nice day both of you :slight_smile:

1 Like

@kabbir86,
Looks like I can reproduce this on my end as well. Reaching out to some team members for more information here.

2 Likes

I couldn’t reproduce this, video played. widevine certainly is needed

@fanboynz,
Then surely widevine isn’t working on my end. Might i add that, i also am unable to run the spotify web verson on my brave pc evven though widevine is up and running.

@Mattches, it’s really annoying, isn’t it?

Maybe disable widevine, via brave://settings/extensions, restart browser. Then re-enable widevine?

I just tried that out with the hope that it probably might work out this time. Not that I haven’t tried it out before.
It didn’t.

I noticed, how your tab refreshes itself as soon as you allow widevine for facebook. It doesn’t do that in my case.

Can you try in new Brave profile?

Same outcome mate. :sleepy:

How did you create the profile?

From the “Create a new Profile” option.

Try the new profile, via windows.

  1. Close all Brave windows
  2. Open in explorer, C:\Users\<username>\AppData\Local\BraveSoftware
  3. Rename Brave-Browser to Brave-Browser-old

Now open Brave, it’ll be completely new, open Facebook and all widevine when the popup shows.

You can always revert by rename Brave-Browser-old

Widevine or no widevine, it’s still the same. Only difference is that i can see a glimpse of the video thumbnail for just 1 second before the “sorry, we’re having…” error shows again.

I don’t think this is a Widevine issue – I kind of wish it was because that would be a step in the right direction. Again, I’m getting the same behavior as @kabbir86 and I can’t seem to do anything to get the content to play.

Will have to dig into this further. @kabbir86 you said you are having issues with Spotify web version – is it the same type of error we’re seeing here or something different? Also, are there any other sites and/or Facebook pages where you see video content failing in this same way?

Spotify tells me to enable the secure playback on my brave browser, even though widevine is enabled. Once again, it works fine on Edge.

I haven’t noticed anywhere else other than that particular page on facebook.

@kabbir86,
For Spotify – can you try going to brave://settings/content/protectedContent and ensure that this option is enabled?

Additionally, if you try and view Spotify web player in a private browsing window, do you get the same results?

I think, this content was enabled by default. I never disabled it. I just checked.

I also get same results in the private browsing mode.

@fanboynz and @Mattches, In the components page, what’s your version of WIDEVINE Content Decryption Module? Mine is 4.10.2209.0. and it shows that it’s not updated. But when i click check for update, it shows “component not updated”. Well, this is something new. :slightly_smiling_face:

image

1 Like

Finally.

I can’t believe i got the solution. Feels like a war is won.

I went to the path,
C:\Users<User name>\AppData\Local\BraveSoftware\Brave-Browser\User Data
to find the folder, WidevineCdm, Properties>Security and re allowed every permission for the profile (Not the administrator one).
I don’t understand why i had to do that even though everything was allowed. This doesn’t make any sense. But worked anyway.

2 Likes