Site broken with https

Description of the issue: An internal URL for my employer that is only available internally is not available as https and I cannot list it on the http problem site due to being private (I don’t want the site publicly known). The site was loading properly until the most recent update, but now it’s completely broken unless I use the Brave private browser. I am getting “ERR_SSL_PROTOCOL_ERROR” and when I try to correct the URL to not have the S on the end, I’m not able to because brave keeps putting it back in secure format.

How can this issue be reproduced?

  1. Visit non-secure http link (internal only so I can’t share it)
  2. Get error ERR_SSL_PROTOCOL_ERROR and message “this site can’t provide a secure connection”

Expected result: This internal lookup tool functions properly from Brave private browser and it loaded properly until yesterday.

Brave Version( check About Brave): 1.58.135

Additional Information:
I have tried looking in settings and turning off the brave security features but it doesn’t seem to impact this problem. I have also disabled the upgrade to https setting but this also hasn’t changed anything. For site settings, I have set “allow” for insecure content.

What else can I do? I don’t want to have to use a private window and would prefer to not switch away from brave. The site doesn’t store any cookies or cache so there’s nothing for me to clear to try and force it to not load with the “s” on the end of http, and I don’t think I can report a broken site since I’m not convinced that doesn’t become public.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.