Brave browser shows websites as Not Secure

Hello, I have just downloaded Brave to my computer. On checking my websites, which all have SSL certificates. I am seeing NOT SECURE in the address bar of my Brave browser. Can you tell me why this is please?

Send the Url so I may check

I have several sites and they all show up with the “not secure” in the Blazer browser window. Although they all have SSL certs. Here’s two as an example,


Have tried the links from the previous message and they don’t show the “not secure.” It happens when using the Edge browser though. Not sure about any others.

Thanks again.

Tested both URLs; What Certificate details are showing? Irregular Date/Time zone can trigger issues with SSL or possibly something between yourself and the server (MITM?).

Tested both domains in Brave Release, Beta and Nightly.

Both URLs seems to be okay according to ssllabs: “A” Rating “A” Rating.

Many thanks, Could be something from my side then, as you said.

Do you have another PC you could test it on? Would be interesting to see what SSL Cert General/settings shows on the problematic PC.

I have had a similar experience at my site. Sometimes I arrive in http:// -mode despite having the SSL. Happens in Edge too but it looks uglier in brave with the big red X and prominent not secure message. Those daring to continue browsing the site tend to end up in https:// -mode after awhile.

We do use the https-everywhere list, which will convert some domains from http into https. Can be tested if you disable the https option in sheilds.
Is there any specific domains with a “big red X” that shouldn’t be?

Wow, that was quick reply.

My site is

It seems if I type the shorter I arrive in ugly big red X mode on the other hand brings me to nice safe padlock mode.

I think its a misconfigured web server, Loaded up Chrome and firefox and they also show its not secure.Maybe the default is the http and not https on the webserver?

https is definitely on the site;

Thanks @fanboynz. :smiley:
Let’s blame my web host. Frankly I have no idea how they have configured the web server.

Update: seems the problem could be fixed by adding some always https code in .htaccess at my side. At least I hope the problem is fixed now.
Thanks for the help @fanboynz and sorry for thread hijacking @gateforthboy


confirmed it is fixed @jonax. @gateforthboy sorry for the thread hijacking

This topic was automatically closed after 30 days. New replies are no longer allowed.