Set "Only Block Cross-Site Cookies" - Get "Allow All Cookies"

On Windows 10 x86, latest update, latest Brave build (31/1/2020), I set the option to “Block all cookies”, then reset it to “block cross-site cookies” and when I went back to the option after closing the page, the option had been set to “allow all cookies”

  1. Set option to “block all cookies”
  2. Reset to “block only cross-site cookies”
  3. Close Settings tab
  4. Open Settings tab, look at result.

Set to “allow all”. I’ve repeated this several times.

Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit)