Search.brave.com lands on a 404 with Brave (but not other browsers)

Description of the issue:

I’m unable to search anything when Brave is set as default search engine in the Brave browser, as https://search.brave.com/ redirects automatically to https://search.brave.com/auth/ with the following message:

"404

Nothing matches the given URI"

And the “Get back to searching privately” button below just sends to the same page.

Brave Version (check About Brave):

V1.32.113

Operating System:

Macos 10.15.7

Same problem with lastest version of Mac and brave…

Same issue on my end.

Won’t work on my m1 MacBook Air but works on my m1 Mac Mini.

Same on Android… Search.brave.com keeps redirecting to /auth and throws a 404 :frowning:

I fixed this issue by moving to the beta.

For you folks having this issue, does the problem occur when you type the address into the URL bar and are absolutely certain the /auth path isn’t being auto-filled?

Yes, /auth is not put in when manually trying to reach the page but after waiting awhile the page comes back with the /auth and the 404.

Same here. When I key in the ULR (search.brave.com) it redirects to search.brave.com/auth automatically.

Can I get a count on how many users this is still occurring for other than @bdown?
Additionally — @bdown, what version of the browser are you using at this time? Additionally, do you have a Brave Premium account at this time?

1 Like

Include me, windows v1.45.133 … not a Brave Premium user

This issue should now be resolved. If not please let me know and I will forward this information to the team.

still not working. windows v1.46.153

Still not working on the latest stable (v1.47.171) on macOS.

@fdrc can you please open the dev tools console window (Menu --> More tools --> Dev tools --> Console and attempt to visit search.brave.com again and take a screenshot and share any console output you see here?

sure, here it is

Can anyone here still encountering this issue please try the usual suspects:

  • Try clearing cache/data for search.brave.com by visiting the site, clicking the “lock” icon in the address bar, then Site settings --> Clear data
  • Try visiting the site using a Private browsing window and note whether or not you are able to
  • Try visiting the site using a new profile and note whether or not you are able to

@fdrc,
The above may not due the trick — we see the issue and are working on an overall fix but in the meantime can you (and anyone else seeing this 404 issue) please try the following:

  1. Visit brave://serviceworker-internals/
  2. Scroll down and look for Scope: https://search.brave.com/
  3. For this entry, hit Stop and Unregister
  4. Relaunch the browser then try visiting search.brave.com again

Let me know if this works for you.

1 Like

it seems like it does the trick! Thank you :slight_smile: (fingers crossed for a permanent fix)

1 Like

@fdrc,
Glad to hear it.
We’ve actually already implemented the fix (you just happened to perform the steps before it was in prod.) — so for anyone else encountering this, please re-visit search.brave.com and you should be able to land on and use the site without any issues.

If it still throws the same error please let me know so we can take a look.

Thank you

1 Like