Right-click Win11 taskbar context menu doesn't show up

Description of the issue: Hi guys, when I right-click the Brave icon pinned on the taskbar, the contextual menu shown should be shown as Saoiray’s menu, but instead it shows like this:

As you can see in the screenshot, mine should have “most visited”, “Recently closed”, “Open Priavte Window” options but it doesn’t. It’s not a big deal, but it peeked my curiosity as to why this could happen, as well as how to solve it if possible. Thanks to Saoiray for showing me this works as intended. I thought it was a lacking feature on Brave, but it’s not. It’s clearly on my own system.
Someone else suggested right-clicking the Brave icon within the menu, but that doesn’t work either, this is what it shows:

I appreciate the help very much.

How can this issue be reproduced?

  1. Right-click on the taskbar icon.

Expected result: Right-clicking the Brave icon on the taskbar, should pull up a fuller contextual menu.

Brave Version( check About Brave):
Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) (64-bit)

Additional Information: Windows 11 22H2 build version 22621.963 - fully up to date if this helps.

Hello @MrLion28

it been while since i used windows so try the following and i hope one of them help

  1. unpin brave from the taskbar then add it back and restart your computer then open brave couple of time then check the menu back and see if it work or not

  2. check this one https://www.elevenforum.com/t/enable-or-disable-taskbar-context-menus-in-windows-11.6234/ try the local policy option but do not try the registry file one (the second option )

hope one of those help and have a nice day :slight_smile:

1 Like

Hey friend, thanks for the response. That didn’t help. But I did learn that they are called “Jump lists” as “context menues” are a different thing, thanks for that one :stuck_out_tongue:

It’s weird because the “jump lists” work for the rest of stuff.

you welcome @MrLion28

could you create new windows user account and see if it work fine with your new account if it does then hope this one nail it :wink:


try it with your new user account to make sure you got the in and out of it

and hope that help :slight_smile:


Edit: It works! I had to… wait a while :S lmao. I leave the text I was writing down blow up, for the giggles. Windows, I guess :rofl:

Thank you very much, it worked! :smiley:

Ok, we have good news and bad news :sweat_smile:

The good news is I made a new account, local to get it quick to test. The thing works!

But the bad news is, I noticed something strange. I DID have deactivated that option on “Personalization > Start”. I thought it was only partaining the Start Menu but it clearly states it modifies the “Jump lists”. Here’s the kicker: Jump lists are not the “full menu” apparently. They’re an addition to context menu from the taskbar.

I say this because on the new local account the menus worked, when I deactivated that option, it removed (as it should) the “recent” pages, however, the “tasks” submenu was still there (intended behavior). On my main account, I DON’T have a submenu at all. So it seems there’s something else going on with it, and it’s not “jumplists”.

1 Like

you very welcome @MrLion28 and congratulations :partying_face:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.