Disable most visited and recently closed context menus

Description of the issue:
Is there a way to disable the context menu indicating “Most visited”, “Recently closed”, and “Brave” when left clicking the Brave Browser icon from the task bar? Both “Most visited” and “Recently closed” clutter up the context menu and “Brave” seems to do the same thing as “New window”

How can this issue be reproduced?

  1. Right click the Brave Browser icon from Windows 10 taskbar
  2. Most visited, Recently closed, and Tasks context menus appear

Expected result:
I would like to right click and only see the context options for Tasks, New window, New private window

Brave Version( check About Brave):
Version 1.9.72 Chromium: 81.0.4044.138 (Official Build) (64-bit)

Additional Information:
This is on Windows 10


I would like an answer to this question as well. Brave is supposed to be the ultimate privacy browser. So why isn’t there an option for users to disable this Orwellian, non-privacy “feature”?

1 Like

Since there is no option via the Brave settings, you can disable this feature in Windows 10 settings.

  1. Open Windows 10 Settings. Right-click on start menu and click “Settings”.

  2. Then go-to “Personalization

  3. 'Click “Start” from the menu on the left-side

  4. Disable (or turn off) the option that says;
    "Show recently opened items in Jump lists on Start or taskbar and in File Explorer Quick Access".

I created a account just to hopefully help you and others with this since someone asked me for help with same issue and sent me this link stating others were having the same problem.

I hope this helps.


Excellent solution – I didn’t even know that this existed myself! :stuck_out_tongue:

Thanks! This takes care of the majority of the clutter that was aggravating me. Still having two shortcuts, “New Window” and “Brave” do the same exact thing is a little annoying but nothing major. I can definitely live with it.

Thanks again, I really appreciate the help!

Glad to hear it helped you sir or mam.

As far as having the taskbar still showing up show up (New window, new private), unfortunately I don’t have no answer for that.

@Mattches Microsoft LOVES to bury subtle options. :wink:

1 Like

Thanks @IreJd! Keep up the good work.
Closing this thread for now.