Rewards are not available in my region

I got message about that Brave Rewards is not available in my region.
Connected Wallet: Uphold.
Wallet registration country: Estonia.
Current country of living: Turkish Republic of Northern Cyprus (Unrecognized Territory). I have a residence permit.
Regional settings for Google and Microsoft accounts: Turkey. Computer regional settings: Turkey.
PC System language: Russian.
Browser language: Russian.|
It happened after OS Reinstall.

I don’t think Turkey is supported, and the country you choose on Brave needs to match the country on the ID you used to verify with Uphold, e.g. Estonia.

You might have to reset or reinstall Brave to be able to reselect your country and choose Estonia, but I’ll let @Saoiray or one of the others answer fully in case system settings are now also a consideration.

Just know that if you reset/reinstall you will lose any BAT remaining on your browser, and I’m not sure if there’s a way to get that back.

@Thrive Actually, Turkey/Turkiye is supported at this time according to https://support.brave.com/hc/en-us/articles/6539887971469 but only for those with existing accounts. Uphold is preventing new accounts.

That said, the error message that OP is sharing is different than the one about region not supported. They referencing error related to https://support.brave.com/hc/en-us/articles/9053832354957-Unavailable-jurisdictions-Brave-Rewards-is-not-available-in-your-region- where Brave has decided to prevent people from participating in Rewards at all.

Turkey/Turkiye is not on that list. However, Russia is. Generally the issue with this message has been because people had their Locale settings on OS set to Russia or one of the places which currently is not able to participate in Rewards.

It looks like OP is saying all regional information is set to Turkey and only thing Russian is language. @Ambulavero I do want to check though, do you have all of this set for right area? Like you see picture shared at Brave Rewards problem in my region - #7 by try2365 ?

For that person, they had Belarus for country but because Regional Format was Russian, it prevented them from linking. Once they changed Regional Format, it no longer showed.

2 Likes

Correct. Thats the solution. I changed exact region format and that helped.
Thanks a lot.

3 Likes