Restore Wallet Failed

I had an active Brave Wallet with a balance using my old Windows 7 OS. I upgraded the HDD to SSD and did a clean install to Windows 10. When I tried to restore my old Brave wallet using the passphrase, it had me enter the passphrase and select a “new password”. I used to same password I had for the old wallet and when the wallet opened, it appears to be an entirely new wallet with no balance.

What am I missing here?


Do you have your recovery phrase written down? You could try restoring directly from your recovery phrase if you have it.

Were you using the legacy Crypto Wallets?
We are tracking a bug where importing a legacy wallet that had a 24-word recovery phrase was broken. The fix should be available in the next nightly release.

1 Like

Yes I have the recovery phrase written down and I used it to restore the wallet. After entering the recovery phrase and password, the wallet opened with no balance. It basically looks like a new wallet.

I mentioned all of this is my opening comment.

I’ve been handling wallets for more than 10 years and haven’t had this happen. This is some janky stuff.

1 Like

By “basically looks like a new wallet”, does that mean the recovery process generated different public key than you previously used? What networks are you using this wallet for? Ethereum, or something else?

1 Like

make sure you are on the correct network as the tokens you had. you may also have to manually add the tokens you had to your list for them to appear.

1 Like

I used the wallet to deposit Filecoin I have. It wasn’t part of any network, such as MetaMask, if that’s what you are saying. Again, I deposited Filecoin into the wallet, so it could be held.

Aside from the initial deposit, I didn’t write down the public key because I had no intention deposit anything else. If I did try to deposit, I would simply copy the public key again.

The main thing to consider here is I restored the wallet on a new OS and fresh download of Brave. Which I have done many times over the past decade. This being the only problem.

I’m not sure what you mean by making sure I’m on the correct network. My Filecoin was deposited into the wallet. The wallet held my Filecoin. No outside network is involved. If the tokens were deposited into my wallet, when my wallet is restored, the tokens should be there. They aren’t.

well I looked up file coin and it appears to be on the binance smart chain network and by default brave is on the Ethereum network. so you will have to enter the bsc network credentials then add the file coin contact address to your list. hope that helps.

I was able to get my old hard drive to load up. From there I was able to get to my Brave wallet and it’s showing my balance. I then tried to withdraw my full amount to get it off this wallet, but the system aborts the transaction telling me “amount the amount has to be greater than 0”. Of course the amount is much larger than zero and I have tried it numerous times allowing for fees etc. The same ridiculous error message each time.

Brave wallet is a clown show!

I’m messing around in this Brave wallet trying to figure out a way to withdraw my tokens and I see next to my Filecoin account it says “unapproved”. What is that? How can it be unapproved if it was accepted into the wallet? How do I get it approved so i can then withdraw?

Who the created this steaming pile of dung? I have never seen a wallet so hand strapped in my life. Besides lacking any intuitive properties at all, why make a wallet so cumbersome to use?

Is there a moderator or a Brave wallet employee who can be contacted to help fix this mess?

I sent you a direct message to schedule a troubleshooting call.

Hi, thank you for emailing me the screenshots, as it helped me figure out the cause of this issue. Try sending slightly less than 100% of your balance, as sending 100% would not cover the small amount of fees needed for the Filecoin network.

@Paulevalsam, please post your issue to the Uphold Brave Rewards forum.

Again, I’m not new to the use of wallets. I have tried numerous times to send an amount below 100%, same error message. I will go back now and try to reduce it by a significant amount ( which shouldn’t be needed as a basic transfer fee for Filecoin) to see if it goes through.

Ok, my issue is fixed. Like I mentioned before, I tried repeatedly to adjust the amount to send to allow the transaction to go through. It failed. Now after you posted here, mysteriously the transaction was not only allowed to go through, but a pop-up window appears stating what the gas fees would be and giving the option to continue with the transaction or not. That has NEVER happened before.

My guess is after I alerted to my problem, someone within the team realized Filecoin wasn’t set up correctly or certain options weren’t enabled and made the correction that was needed.

Regardless, my tokens are finally removed from this wallet, so I no longer will have to deal with this mess.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.