Recent updates have caused extremely high CPU usage

Description of the issue:
I don’t tend to close my browser except when I’m rebooting the computer so the version I was previously using (with no issues) is at least a few weeks old. There was a queued update that I never got around to doing until today. The problems began when I installed the long-queued update.

Opening the freshly updated browser caused my CPU usage to skyrocket and stay pegged close to 100%. Everything was very sluggish. Pages sometimes seemed to not respond at all. In the middle of trying to copy the version number Brave found another update. I allowed that second update to download and install. There does not seem to have been any change in the issue.

How can this issue be reproduced?

  1. Open the browser.

Expected result:
Previous smooth operation.

Brave Version( check About Brave):
(don’t know the previous versions, sorry)
Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (64-bit)

Additional Information:
An anecdote to illustrate the dramatic difference in usability between versions.

A week ago I was actively digging through some Wayback archives on a defunct website and had probably close to 200 Brave tabs open with little-to-no discernible slowdown. Today I have ~20 pages of mostly static programming documentation open and I had to switch to another browser to make this post.

Here is one image of my Windows Task Managers and one of the internal Brave task manager. The Brave release notes page is taking 500+mb of RAM on its own. >.>

Certainly is not an issue with Brave alone, and certainly is not an issue with Windows 10 alone. Because, me and other users, are still able to use both without troubles.

It would be great to be able to identify what is actually causing this. Maybe more information about other potential SW would help. Extensions? Antivirus? Firewall? Installed versions (Win10 and Brave)? Graphical card? Brave configurations?

One well known configuration that affects performance in Win 10 is hardware acceleration. Try to deactivate it in Settings > System.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.