Problem with widget, brave becomes unresponsive

Description of the issue:
A very new user here.

Everything so far is an excellent experience, changing over from firefox in a windows 10-64 bit on a slow computer, Brave is noticeably faster. Great improvement.

But, when viewing a certain webpage, it chokes.

The page is

everytime I select a currency other than USD, I get a popup saying “Pages unresponsive” noting that the problem is with

I changed all my brave shield cookie settings, but it still chokes on the currency change.

Am I missing something? This currency change button works fine in firefox btw


Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

all prices are relisted in other currencies.

Reproduces how often:


Operating System and Brave Version(See the About Brave page in the main menu):

Windows 10 Home /64bit / Version 1809

Brave Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)

Additional Information:

Thanks for reaching out — great write-up for your first time!
Would you mind showing me your Shields settings for the site as they’re displayed in the Shields panel (see image)>?
I’m able to change currency without issue testing on my end:

thanks for the reply.
btw, right after I select the new currency, in my case to canadian, the page is reloaded and comes back as USD.

That’s very strange – while I can get the site to recognize the correct currency – after a while of using the site it freezes and eventually crashes the browser.

I’ll have to look into this further. In the mean time, can you try to change your currency on a different page? For example, if you just click the American Eagle gold coins link in the sidebar there and change the currency from that page, do you get the same results?

Hi again
Same result on a different page: reloads page and comes back as USD with any currency option.
Otherwise, everything else on other sites is working very well.

This topic was automatically closed after 30 days. New replies are no longer allowed.