Playback controls broken with hardware acceleration enabled

Description of the issue: When hardware acceleration is enabled on M1 Macbook Pro running macOS Big Sur 11.1, rewind buttons, volume control, playback speed, subtitles button, next episode button in a netflix video is missing. These buttons are still there when the mouse pointer is hovered above the location, but the icons do not appear. This also occurs for Youtube, Amazon Prime in addition to Netflix. On Amazon Prime, “Customers also watched” section movie thumbnails are missing along the playback button.

This happens in both full screen and non-fullscreen playback.

Steps to Reproduce:

  1. Ensure Hardware Acceleration is enabled for Brave.
  2. Visit Netflix or Youtube and select a video of your choice.

Actual Result:
Full Screen

Half Screen

Expected result: All buttons for video streaming sites should be shown and clickable.
Full Screen

Half Screen

Reproduces how often: Always.

Operating System and Brave Version(See the About Brave page in the main menu):

  • macOS Big Sur 11.1
  • Brave 1.18.75

** Additional Information:** Here’s an issue that is related to this one.

Additional photos for YouTube:

With Acceleration

Full Screen

Half Screen

No Acceleration

Full Screen

Half Screen

Additional Images for Amazon Prime:

With Acceleration

No Acceleration

Could you try in Nightly, brave-v1.19.71-darwin-arm64-symbols.zip M1/Arm builds https://github.com/brave/brave-browser/releases/tag/v1.19.71

I only have a older Mac pro laptop to test against.