Opening links as a new tab crashes

Hello,
I am running into a strange error where suddenly whilst using Brave new tabs will stop working. That is, if I open a link as a new tab, it will fail to load. As well, if I try to open my own new tab and type a URL, or type a URL in to the crashed tab, it will not perform any action. The developer tools will also not open.

The way I have found to solve this issue, is to either close Brave, or if I open a new window, all the tabs begin to work again.

This keep happening periodically. I have also found that the currently open tabs will keep working normally.

To reproduce:

  1. Open Brave to a website.
  2. Continuously open a link as several new tabs.
  3. If they all load without error wait a minute or two and repeat until they stop working.

Expected result:
Any new tabs will either show blank with a crashed tab icon, or show blank and will not navigate a URL.

Brave Version: Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (64-bit)

Additional Information: I have already attempted to fixed the error by clearing the cache and browsing data, creating a new profile, and uninstalling and reinstalling Brave.
There is also no record in Brave://Crashes for these despite the screenshot calling it a crash.

1 Like

When you tested in the new profile, did you also make sure no tabs or windows from your other profile were open?

Yes, and it still had the same issues.

OK. Well, we’re at 1.43.89 now. Do you still have the issue on that version? I believe some weird crashes were resolved in the last release, so before going further it would make sense to check on that version.

I am on 1.43.89.
It’s been happening regardless of the Brave version.

@Cauchpotato This is going to feel like going backwards since you mentioned trying new profile and all, but I just want to confirm. Have you tried disabling all extensions? I noticed you had a few extensions going, at least in your screenshot.

In the past, we’ve had some oddball circumstances where apps caused issues even in new profile or private window. Also was uncertain if you’ve had extensions running in any or all of your other attempts.

Also, are you using an antivirus? VPN? Firewall? I know sometimes those things can cause some very weird interferences with Brave, so figured I’d run that by you and see what you can find out.

I do find it weird that it’s crashing but not showing any crashes at brave://crashes. Guessing most of my things may not even put a scratch in your issue, but it was just a couple little things to throw out there since I hadn’t seen it mentioned yet just in case somehow it got overlooked.

I’m going to tag @Mattches over here and hope he can swing by to help. Especially since it seems you’ve had this issue over a month now.

Oh yeah, btw, which version of Windows are you using?

2 Likes

Would also like to know the answers to the questions @Saoiray asked.

@Cauchpotato if you’re still with us here…a new update just rolled out today. They had a few fixes on things that were causing crashes. Can you make sure to update to Version 1.43.93 and see if your issue still persists? If it does, try to reference information I asked in prior post. As you see, Mattches also responded, so hopefully we can help you get it figured out. Just need to have info and updates from you.