Older version not working on newer Mac OS

Description of the issue:
Running Mojave, updated to current Brave (without checking System Reqs) from older version (don’t know exactly which but pre v1.57.64), but new version is incompatible. Looked thru Github list to find latest working version for Mojave (v1.57.64 Chr.116) but after install, icon has circle and line through it with error message saying ‘Can’t use this version, you have os 10.14.6, this requires 10.13 or later’ !?!

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Tried un and re installing, rebooting.

Actual Result (gifs and screenshots are welcome!):
Can’t get a working version

Expected result:
A working browser!

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
Mojave 10.14.6 Brave v1.57.64 Chromium 116+

Additional Information:
Tried an even older version from December 2021 and get the same message saying I need os 10.11 OR LATER!

Any help greatly appreciated as I love Brave!xx - Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.