You can’t use this version of the application “Brave Browser” with this version of macOS

with todays latest update I can no longer access Brave browser, I have a lot of important data which I cannot access now. I received this message “You have macOS 10.14.1. The application requires macOS 11.0 or later.”

I cannot upgrade as my hardware is very old so have now been limited to use other browsers.

I hope a upgrade can revert the compatibility,

many thanks for any insight!

1 Like

Go to the MacOS App Store, then search macOS 11.0 or the recent version, before you upgrade, I would STRONGLY suggest you back up ALL your data on an external hard drive, as you may lose data while upgrading, you don’t need to, but it’s better to save your data just in case. Then you’ll be able to use the Brave Browser. Hope this helps! :slightly_smiling_face:

PS: Your hardware/Mac can be still upgraded even though it is old, it may take longer, but better for any insights!

This scared me… I still have 10.11.6, and Brave Version 1.28.105 Chromium: 92.0.4515.131 (Official Build) (x86_64) works here. It says it’s up to date. Is that the version you refer to?


I cannot upgrade as my hardware is very old

… nor do I for that matter.

edit: Note that I more than once reported some issue on 10.11.6 and I got support – and the issue fixed.
This compatibility problem surprises me big time.
Can you confirm that you are using the official release version?

1 Like

No, it can be any version. I think that 10.11.6 works, but they didn’t put it when you have an older version.

PS: I meant if your OS does not support the browser version and it shows that message "It only works with (any version which works with it) or later.


I am using Mac OS 10.12.6, and the same Brave Browser version as you.

To my surprise, this morning, Brave Browser is very sluggish. Turns out, that the browser and the website (somewhere, therein) has been downloading and installing software other than a new version — all done in the background, and some of the downloading using UDP protocol instead of TCP protocol.

Brave hostnames:

in particular.

In addition to which, other websites are quick, but the Brave Community website has been slow to display.

And, no way for me to have new computer equipment that keeps up with BB versions espousing: “You can’t use this version . . .”

Those two hostnames seem legit. I don’t know what is go-updater but componentupdater must be the one hosting updates for brave://components – BTW I just noticed that first time download (and updates I suppose) come from laptop-udpates.
I haven’t yet looked into the update process, I don’t know – but I’m curious too.

Component updates shouldn’t cause the issue described here though, even if there were to be incompatible binaries.
Brave should fail after attempting to run in that case, as opposed to macOS refusing to run the application in the first place.

It’s quite strange that we both have latest Brave running on 10.11.6 (me) and 10.12.6 (you), yet it refuses to run on a 10.14.1 requesting minimum 11.0 – it doesn’t make sense at all.

Anyone on 10.14.x to help?
I’ve read that in 10.14 there have been changes to how application compatibility is handled, and that it has some issues, but that was about 32 bit applications.
I did not find anything that looks relevant yet.

All this leaves me very puzzled – and a bit worried that a future upgrade could bite me in the rear.

To confirm, you’re now using Brave v1.28.106? Brave should be fine with macOS versions 10.11 and up.

Can you try visiting the website and re-downloading/installing the browser? Note that you do not have to delete anything – just download and run the installer and it will re-apply any updates. No data should be lost or overwritten but if you feel skeptical, go to ~Library/Application Support/BraveSoftware/Brave-browser and make a safe copy of this folder.

Thanks everyone for the replies ! this method is the first I tried and it worked successfully!

1 Like

Hello there

I have the same problem. However I have the a little older version than yours. Any advice on how you fixed the problem. Haven’t been able to use Brave over a week now.

Tried downloading from the installation file to install but it does not fix for me. My laptop is older too with low space so did not upgrade. I don’t know how this happened all of a sudden. I’ve attached some screenshot. Will appreciate the support. Thanks


You should try my method I mentioned above.


Mattches at Brave Support, reply 7 above, says “Brave should be fine with macOS versions 10.11 and up.”


In your reply 8 above, what was “this method” that you first tried, successfully? Tx.

Hello thanks for the reply

Okay…how come its not working for mine? Did you see the screenshot?


I saw the screenshot.

The following is lengthy. Please read carefully. Getting familiar with all the locations of the items mentioned, will help you a lot, before taking steps.

Some of this may be familiar to you, but I do not know how familiar you are with your Mac. So . . .

Please Quit all Brave Browser applications.

Where some things are at, using Mac OS X:

Root: simply a forward slash /

Root and System level folders


The “Brave” application is located:

/Applications/Brave Browser/

There, and hereafter, I am referring to the location of files and folders - assuming a stable release of Brave Browser is/was the only installed version. (No Brave Browser Beta’s. Nor Nightlies.)

Your machine user account folder, aka home folder “your_username_aka_shortname”:


Therein (of interest today):



System level Cache files - generally you do not mess with these very often:


On the other hand, your user account “Library” folder and its “Caches” folder:


Generally, therein, you can - after quitting associated/relevant application(s), move your cache files n folders that you select

/Users/your_username_aka_shortname/Library/Caches/< files n folders >

to the Trash. For example, there are (Mac OS 10.12.n Sierra) two Brave Browser cache directories that could be moved to the Trash, “BraveSoftware” and “com.brave.Browser”:

Screen Shot 2021-08-13 at 9.53.56 AM
Screen Shot 2021-08-13 at 9.55.12 AM

Application Support

System level Application Support:

/Library/Application Support/

Currently (Sierra example) - there is no “Brave Browser” type folder therein.

On the other hand, in your user account’s Application Support:

/Users/your_username_aka_shortname/Library/Application Support/

might have a Brave Browser folder named “BraveSoftware”

I suggest that you Compress (.zip) that “BraveSoftware” folder (if it exists on your Mac - you might show a different folder name). The Compress command is under the File menu of the Finder. First, select the folder that is to be .zip compressed, and then under File (menu), select Compress. Give the resulting .zip file, a name showing the date; for example: “” . . . and thus, you have created a backup, “just in case.”

Next, let’s take a look within:

/Users/your_username_aka_shortname/Library/Application Support/BraveSoftware/

And therein, a sub-folder “Brave-Browser”:

/Users/your_username_aka_shortname/Library/Application Support/BraveSoftware/Brave-Browser/

And, therein, several files and folders . . . something to consider:

Recently (last few days of the 2nd week of August 2021) there were some temporary fixes / solutions to Brave Browser problems (for some users), where CPU/RAM usage has been high, and/or failure to successfully start Brave Browser (crashes or freezes).

Among the temporary fixes, were TWO that might apply to your situation (though their influence may not be apparent on the surface of what is happening with your Mac). So, after Quitting Brave Browser:

ONE: Move to the Trash, all the contents within the “CertificateRevocation” folder (but not the folder itself):

/Users/user_shortname/Library/Application Support/BraveSoftware/Brave-Browser/CertificateRevocation/

TWO: Move to the Trash, the “cffkpbalmllkdoenhmdmpbkajipdjfam” folder:

/Users/user_shortname/Library/Application Support/BraveSoftware/Brave-Browser/cffkpbalmllkdoenhmdmpbkajipdjfam/

Example screenshot of both a) the contents of folder “CertificateRevocation” and b) the “cffkpbalmllkdoenhmdmpbkajipdjfam” folder, currently:

Screen Shot 2021-08-13 at 11.06.38 AM

You might take a swing at THOSE TWO TEMPORARY FIXES just mentioned . . . AFTER you:

First, Repeat reminder to Quit Brave Browser (including any Beta’s, Nightlies).

Second, un-install whatever Brave Browser applications you may have installed by now.

Third, move to the Trash, the aforementioned cache collections of your user account on your Mac.

Fourth, Locate the Preferences file “com.brave.Browser.plist” for Brave Browser:


And move that “com.brave.Browser.plist” file to the Trash.

Restart your Mac.

THEN, after all that cleanup, install the latest stable release of Brave Browser:

IF THEN, the latest stable release of Brave Browser will NOT install, you will need Brave Support help, directly.

Because probably a required signature credential for the Installer (or some part thereof), is not correct, or some Bundle Identifier info, is not correct (something like that) - would be my guess.

(PS. Sometimes, the date info, of your computer, might be off enough, such that an installation will not proceed.)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.