Odd behavior on Amazon website

Every time I go to amazon.com in Brave on a MacBook Air, the search box at the top of the Amazon page automatically opens and displays searches I made weeks ago. This only happens in Brave and no other browsers I have. I’ve cleared all caches, history, etc. I don’t know how to make this stop.

Could you try the same in the private window?
If it works good.
Then try disabling extensions one by one.
If that doesn’t work, clear cookies.

1 Like

Private window doesn’t have same problem. I only have one extension–LastPass. I disabled it, and the problem went away. I re-enabled it, and the problem did not return. Thanks a lot. This was very annoying.

1 Like

Hello @MichaelB

Thank you for reaching us and sorry to hear you’re having trouble with Amazon website on Brave. Could you kindly logout and login again to Amazon on Brave, to see if this solves the issue.

Please, let me know if that works and have a nice day!

Great. Yea, sometimes extensions cause issues.