Not seeing embedded tweets in Brave for MacOS

I love Brave but, for months now, I haven’t been seeing embedded tweets in any article on any website when using Brave on MacOS. Yes, I have the latest update of Brave and the latest update of MacOS Monterey. This issue has been going on for months, so this has happened with multiple recent Brave updates and MacOS updates that have come out in recent times.

When opening those same articles that include embedded tweets, I see the embedded tweets with Brave on mobile and I see them with any other browser on MacOS. But no embedded tweets are shown on Brave for MacOS (for me).

And I feel like I’ve done it all, before someone suggests something obvious.

  • I’ve tried disabling shields for those websites that had the embedded tweets (maybe Brave was mistakenly blocking the tweets thinking they’d be ads), but it didn’t work.
    -I’ve tried disabling shields for and then seeing if embedded tweets showed in other pages/articles. Nope.
  • I’ve checked dozens of times if the option to see embedded Twitter posts was on in my browser or if it was ever accidentally turned off. Nothing – the option has always been on and yet those embedded tweets haven’t been showing for months.
  • I’ve looked at alllll the flags in brave://flags/ as well as all the settings and there’s just nothing there to address this issue or fix it.
  • I’ve even tried to delete Brave(!) and reinstalled it. Nothing.
  • I’ve also left one Brave sync chain and joined a new one to see if perhaps some weird settings had carried over in syncing things. Didn’t fix it.
  • I recently changed my Macbook since I got one of the new ones with M1 Pro. Brave on the new Macbook didn’t fix this issue. (Yes, I made sure I am running the Brave for M1 app, but that’s besides the point and definitely didn’t fix the problem, either).

It feels like there’s nothing on my end (in Brave settings on MacOS) that I can change to fix this. Help? Thanks.

Can you give an example of a page with this issue?

Is SpeedReader enabled?

What extensions are installed?

If you create a new profile, does the issue occur in the other profile as well?

Caveat: I can test with Brave for Windows and Linux, not macOS, but maybe to start we can at least see if the issue occurs on other systems as well.

@JimB1 is asking great questions here so def respond to those, but in addition can you please provide me a link to a site where the embedded tweets are missing so that I can test on my end?

@JimB1 @Mattches

I mean, sure, I can provide examples, but as I explained in the original post, it can be any page containing embedded tweets. I can’t see embedded tweets on any website that contains them. I can see tweets on, of course, but I’m talking about embedded tweets on any other site. Here are examples just for the sake of what was asked (again, I can’t see embedded tweets or any article/website that contains them).

On that note, I appreciate you testing in Windows and Linux, but I’m running MacOS, so not sure how accurate that test would be for me.

My Brave extensions are only 1Password and Grammarly. That’s it.

After creating a new profile, the problem persisted, yes.

Thanks for the info; it’s important to help us help you so I appreciate you ponying up the links so we can get as close to apples:apples comparison as possible.

I tried the first link (the Bachelorette one) and I see the embedded Tweets. Again, this is on Windows… but to address your earlier question, for something like this I think it’d be unusual for it to impact one platform and not another. But I’ll do the best I can with what I’ve got and we’ll see where it goes.

Are you using Secure DNS in Brave settings at all? If it’s enabled, what’s it set to?

@JimB1 @Mattches

After months of struggling with this issue, you guys made me curious to look into the code. I opened the same pages on Brave and on Chrome - the embedded tweet code on Brave was showing “blockquote” aka it wasn’t being rendered as an HTML element, it was just “quoting” what the tweet said. On Chrome, the code looked more normal as an embedded tweet. I played around with a few flags I had on Brave and nothing changed… until I selected to disable the “Experimental Web Platform features” flag. I’m not sure why this flag out of all the flags would be breaking embedded tweets, but I have now disabled the flag and embedded tweets ARE BACK TO SHOWING for me again lol.

Thank you two for the help/inspiration for me to look into the code. My problem has been fixed. Still curious to know why that flag would break embedded tweets, but hey, I’ll keep it off if it’s gonna break tweets for me.

Thanks again


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.