Not able to log in on my.playstation.com

BRAVE
Version 1.7.92
Chromium 80.0.3987.163
64-Bit

When visiting my.playstation.com (or any link directing to Sony Playstation Store, I can’t log into my account. Not with deactivated shield, nor with the options “all cookies allowed”. It’s always telling me:
A connection to the server could not be established. (18.8c501702.1587329054.893c642)

Unfortunately theres no launcher or software from Sony, so I have to use the web login.

Thanks for your support in advance.

Just Allow all cookies

Well, as I already told, “allow all cookies” doesn’t help at all.
sony

Same when switching the shield off or allowing all cookies globally.
Anyone has any other suggestions?
Login with other browsers works fine.

Here is another screenshot, so you can see, that I really allowed all cookies.
I mean, it’s german but you can still tell what it says, I guess.

Tested in Chrome, seeing the same issue

Just tested in Chrome as well:
I get the 2fa request, entering the code and so I’m able to log in.
In Brave I don’t even come this far. No 2fa request or code sent.

Well, just found the other thread from April 17th. Here you wrote “no eta on fix, but aware of it”. So you can merge the threads and/or close this one. I’m gonna be looking at the other thread from now on.

So what is the score?
We can’t login to the Playstation website, it’s not like this is minor.

Whereabouts is this? Thanks.

@DanData,
Thank you for reaching out to us. This is actually a known issue that the team is working on. You can track the progress of this issue here:

@Mattches

It looks like that PR was closed without merging, is this still being worked on? This is annoyingly still an issue and makes it impossible to use any Playstation services.

This bug can easily be reproduced on a clean install, I tried it on 3 different machines and all failed to login (2 never even had Brave before).

Edit: Btw the work around of allowing all cookies (even disabling all shields) does not help.

@potatman,
It looks like it’s been pushed back – It seems like we originally wanted to release it in the 1.9x releases but some tests were failing so it’s been delayed:

It looks like the linked PR was merged and deployed in 1.9.76, but the issue still persists. Perhaps there is an other cause for the site not working?

On Version 1.10.90 Chromium: 83.0.4103.97 (Official Build) (64-bit), it is now working but with caveats…

You must totally disable shields on sign in page, not the playstation site or playstation network site.

edit:

I forgot, you do have to change the shields setting on the playstation site to allow all cookies… and I tested on my windows vm with no issues…

1 Like

@megaspaz,
Thank you for testing that – much appreciated and glad it’s working, even if Shields have to be lowered. We’ll keep working to find a way around this if possible.