No Tab Groups on tablet with Android 10/11

Description of the issue:

No Tab Groups working on Brave on my new tablet with Android 10 (and now Android 11 after update).
Appropriate flags are enabled but there is no option in menu to open in new group.

How can this issue be reproduced?

  1. Use new Samsung Tab S6 Lite with Android 10
  2. Install Brave and turn on tab groups flags
  3. On any website press on a link and wait for a menu

Expected result:

Menu should have an option “open in new tab in group”, but it is not there.

Brave Version( check About Brave):


Mobile Device details

Samsung Galaxy Tab S6 Lite. Android 10.

Additional Information:

Although swiping left or right on the address bar switches to another tab, the swipe down does not bring you to a preview of all tabs as it should, it just does nothing.




Anybody please.

Can someone investigate the issue.
Brave has lost all the power without tab groups.

On my old phone with android 5 it works fine, I’m able to group tabs and can preview all tabs at once (grid view), but on my new tablet with Android 11 it is impossible.
Now Brave seems to be the only mainstream browser that doesn’t support such a basic feature.

Have a look here, even stock Samsung browser beats Brave to the ground by displaying tabs in grid view:

Where should I publish this problem in order for it to be read by someone of authority?

Also interested. Was about to migrate over to Brave but guess I will wait and see how this pans out.

I believe chrome://flags/#tab-groups-collapse is the solution, but currently unavailable.

Hi @ll, I’m from Germany and have the same issue with my tablet. It’s a Samsung TabS5e with Android 10. On my cell phone I have the option for grouping tabs but not on the tablet. I already tried the same in chrome//flags but still no grouping.
Is there any chance to get this?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.