No red for rgb in netflix player

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
The Netflix player works great, video is smooth, audio is clear and smooth, and all that, EXCEPT that there is no red in the RGB video. So, faces are blue, red objects are gray, yellows are green, etc. Still images on the Netflix home/browse pages are fine, only the player is affected. Players for other streaming services (hulu, prime video, youtube, etc.) work as expected. Netflix color is fine using Firefox on the same computer. This seems to have started when i updated to Brave browser version 1.64.109

How can this issue be reproduced?

  1. Launch Brave browser
  2. Navigate to https://www.netflix.com/ and log in
  3. click on a show or movie to start the player

Expected result:
Video will play with normal color, i.e. full RGB colors

Brave Version( check About Brave):
Version 1.64.109 Chromium: 123.0.6312.58 (Official Build) (64-bit)

Additional Information:
running on arch linux:
kernel release 6.8.1-arch1-1
sway v 1.9 (so, using wayland)

Interestingly, on the same system, Netflix colors are fine when running Brave under i3wm, so using xorg rather than wayland.