Wrong color rendering on 30-bit displays on Linux (possibly on other platforms)

linux
#1

Description of the issue:
Colors on 30-bit color depth displays have undefined bluish cast. The problem is on the entire browser including menus and toolbars.
Chromium renders correctly so it is something specific to Brave

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Start the browser and compare colors with Chromium

Actual Result (gifs and screenshots are welcome!):

Expected result:
Correct colors

Reproduces how often:
happens every time

Operating System and Brave Version(See the About Brave page in the main menu):
Brave: Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)
OS Debian Stretch 64 bit on all the window managers: KDE, LXDE, XFCE, Gnome

It appears that the problem is not related to the desktop used.

Additional Information:
It must be some flag you use because by default Chromium does not have this problem. This is the single most issues that prevents me of using Brave as my default browser.

#2

Thanks for reporting @bhlevca.

First can you update your Brave to the latest release and see if the issue still persist?

And can you try disable “Hardware acceleration” under Menu > Settings > Advanced?

Thanks
:slightly_smiling_face:

#3

Unfortunately there is no brave binary for my OpenSuse distribution (something you should consider doing) and I am using the snapd version which does not have any newer versions and I don’t have the time to build one from sources yet.

I also tried to disable hardware acceleration buy it did not help. Perhaps are there any flags I could try?

Being build on top of Chrome/Chromium (which do not have this issue) I guess it is something Brave tweaked.

Please investigate because I really like the browser, but being a photographer 10bit/channel color is a must.

Thanks

Update : I tried version 0.64 and it has the same problem.

#4

Anyone who has a wide gamut monitor looking into this? Basically as a photographer I need 10-bit/colour . If this will not be fixed I will need to move to other browsers that support that and frankly all Chromium based browsers work: Chrome, Vivaldi, Opera. Consequently, I don’t think that it is a Chromium problem but a Brave problem or setting. If I am guided in the right direction I can try to experiment with various settings

#5

This bug will be automatically closed in 5 days why? Shouldn’t someone go give it a resolution first? IS there another bug entry system available?

This is potentially a showstopper for many people whether it is a configuration problem o a real bug.

I am still hoping that it will get at least reply and an answer on whether it will be fixed or not so that we know if we will use brave or not. Thanks

closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.