New install keeps switching monitors

bug
windows

#1

Description of the issue:

New install, while going through the initial configuration steps, Brave kept switching monitors, back and forth between my main and secondary.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Install Brave
  2. Wait. Close or open a tab.
  3. Watch it switch back and forth between primary and secondary monitors every time.

Actual Result (gifs and screenshots are welcome!):
It… switches monitors.

Expected result:
It won’t switch monitors, unless I tell it to.

Reproduces how often:
Well, it’s been going on since I first launched it, so maybe 10 minutes?

Brave Version(about:brave):
Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

Additional Information:
Windows 10, dual-monitor setup, running DisplayFusion from Binary Fortress. This does not happen with any other program; a completely novel issue.

Edit: New information from observing behavior. Seems to trigger whenever a tab is closed or opened. Nope. Just whenever a tab is closed. Does definitely switch back and forth, though.


#2

Hi Landshrk,

I was experiencing a very similar problem, I have only recently installed Brave after being recommended it from a friend and have been enjoying, however I too run Displayfusion Pro (v9.4.3 as of this post) and noticed the window snapping to my alternate monitor or vice versa.

When Displayfusion is closed out of completely, Brave works as intended, but as soon as it is reopened I noticed Brave’s windows began snapping to the opposite monitor each time. Slightly different to yourself, I was not experiencing this with a new tab, only closing a tab.

I realised a setting in Displayfusion that once turned off I was not receiving the window snapping anymore:
Settings -> Windows Management -> Untick “Enable window caption bar middle-clicking to move windows to the next monitor (hold shift to move to previous monitor).”

The way I figured out this was not occurring when I turned this off was because I always closed the tabs with middle-clicking rather than the small “X” which I think is fairly common practice from users of Chromium based browsers, when I did utilize the “X” this did not occur at all.

I believe this is a bug with DisplayFusion Pro, not necessarily Brave, as there is about a 2 second delay before the screen switches sides after middle clicking a tab closed, I have temporarily disabled this setting and sent a message over to Binary Fortress for them to investigate.

I hope this will help you with your problem! I tried various other settings turned off, such as window snapping, Ctrl + Win + X prompt on all windows turned off and disabling the multi-monitor desktop background to no avail. Goodluck! Otherwise, perhaps Binary Fortress may end up patching the issue.

Kind regards,

Daemonic


#3

Thank you both for reaching out.
We have actually had this reported quite a few times before. One of the stranger issues open right now, imo.

This new information about DisplayFusion is useful too. Here’s the issue filed on our GitHub, I will add this report to that thread on your behalf:


#4

Thank you! That actually makes a lot of sense!

Went ahead and made that change in DisplayFusion, and it worked like a charm. So, again, thank you!

It’s too bad that’s the fix, because I use that shortcut pretty regularly. However, since switching from Chrome to Firefox as my main browser (though now that I’m playing around with Opera and Brave, that may not last too long!), I’ve had to start using the little icon displayed just to the left of the window controls, as in Firefox, middle-clicking anywhere on the titlebar will only either close a tab or open a new one. So yeah, Brave isn’t the only browser out there that has this issue!


#5

Much appreciated! I’m really starting to love this little browser, and with the workaround that Daemonic posted, the biggest issues I’ve had so far is now manageable.

I appreciate the work you all are doing here, giving us a lot more options than just Chrome and Firefox.

Now to get that Sync feature a little more robust! :smiley:


#6

Just you wait!

Glad you got this resolved - information uncovered here is also quite useful. Appreciate you both for starting the discussion.


closed #7