NET::ERR_CERT_VALIDITY_TOO_LONG Error when trying to connect to my company's internal site

Everytime I try to connect to my company site I get the NET::ERR_CERT_VALIDITY_TOO_LONG error. I know why this happens and want to connect anyway, but the option is not given to me. When i get to the part when I need to use my smart card to log in the error happens. I used to be get the option to connect anyway (about 2 or 3 weeks ago), but now I do not. I need the option to connect regardless or i cannot continue to use the browser that works wonderfully otherwise. Thank you for your time.

Edit: I get the same error using google chrome, but it gives me the option to connect anyway.

Hi @soupy,
Can you try connecting but with all cookies allowed setting selected in the Shields panel?

I have tried allowing cookies with no change. I have also tried taking all shield settings down with no change as well.

Can you try creating a new profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create a new profile.

New Profile worked, but old one does not. Are there any particular settings that you can think of that might cause this?

@soupy,
There might be an extension causing the issue. Can you try disabling all of your extensions? If that solves the problem, the next steps would be to enable each extension one by one, and seeing which one causes the issue.

The only extension I use is google translate. I disabled that and see no change.

If it’s not an extension, then it may be your settings, if you’re willing, you could go to brave://settings/reset, and reset your settings.