Problems opening newest version of Brave on Windows 10

Hi Guys I have a problem opening the windows browser

  1. I have installed the windows 10 Brave Browser latest version but after installation it does not open. The mouse produces a blue circle but nothing happens
  2. I have deleted and installed the browser a number of times and the same thing happens.

Please let me know how I can get the browser to open.

Thank you for the help

Hi @dancoza,
To confirm you were never able open Brave? i.e. this is your first time using it?

1 Like

Yes. I have never been able to open the brave browser.

he ment that did you used brave and was able to open it before update or that your first time to use brave

have a nice day :slight_smile:

I have the same issue. I have been regularly using Brave before updating to the latest version. After that i installed a cumulative windows 10 update. After the installation Brave would open and remain open for about a minute, then it suddenly crashes.
I tried uninstalling and reinstalling multiple times, no luck still.

To clarify it was the first time I had downloaded the Brave Browser ever and it has not opened at all.

It was my first time downloading brave and I have never been able to open it

Hi @dancoza,
Apologies for the late reply are you still having issues? If so, can you try re-running the installer?

Hi @Aa-ron

I am still having problems and I tried to rerun the installer and do the whole installation process from the beginning. my steps were as follows:

  1. delete the brave browser
  2. delete all installation packages previously installed.
  3. download the installation file
  4. reinstall the brave browser.

this still did not work.

what else can I try

Can you try clearing your Prefetch folder? Try going to C:\Windows\Prefetch and emptying it.

Hello, I’m Matt. I love your browser It’s so good, but I’ve been having issue with your browser. When I go to one of my favorite YouTubers It just shows a white screen.

could you try to visit it using the private mode

hope that help and have a nice day

@NewEl3mentz,
Your issue is unrelated to this thread. Please open your own topic.

Hi

Thank you for the reply.

I deleted the contents of the folder and tried to run Brave- this still did not work.

I than deleted brave again, deleted the contents of prefetch folder- this still did not work

@dancoza,

Can you try disabling Hardware Acceleration ?
Open Command Prompt and enter this command:
"C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --disable-gpu

If that does not work, can you also try:
"C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --disable-sync
You probably don’t have Sync enabled, but I still want to give a try.

Dear @Aa-ron this solution did not work. Unfortunately.

Hi @dancoza,
Can you try disabling windows defender and reinstalling ?
As mentioned in this thread:

Hi @Aa-ron
I am sorry but this also did not work.

i have silly suggestion uninstall brave then go delete the the brave folder in the local folder
C:\Users\YOURUSERNAME\AppData\Local\ delete brave folder from there

then disable antivirus then right click the installer then run by administrator then after installation finished right click brave icon and choose run as administrator

do not know if there issue with your os permission or not

hope that help and have a nice day :slight_smile: