Missing spell check entirely in Settings

bug
#1

Description of the issue:
I don’t have spell check settings anywhere. My understanding is that it should be in the “Languages”-section. Searching for “spell check” (and similar) in Settings does not produce any results. Please let me turn this off!

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Not sure. I just (about an hour ago) downloaded Brave and imported Settings from Chrome.

Actual Result (gifs and screenshots are welcome!):
Attached screenshots:

Expected result:
Seeing spell check options.

Reproduces how often:
Constantly.

Brave Version(See the About Brave page in the main menu):
Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

Additional Information:
I use a 12" Macbook with OSX Mojave 10.14.3

Thank you in advance!

1 Like

#2


0 Likes

#4

Obviously it works for other people, or it wouldn’t be a bug. Those screenshots are not the least bit helpful, because it looks entirely different to me.


1 Like

#5

i have dev version brave, you need install brave from here https://brave.com/download-dev/

0 Likes

#6

Hm. I’m not generally fond of using the dev branches, but I guess I have no choice. Thank you.

1 Like

#7

:stuck_out_tongue_winking_eye:

0 Likes

#8

While I did get the flashy new Settings page, I still didn’t have any spell check options. I feel targeted. :<

0 Likes

#9

Welcome to the Community @psynisk :wave:

Stable release, Beta and Dev version should have spell-check settings.

Let me cc @Mattches @sriram @gsarvadnya for assistance here because I don’t have MacOS. :sweat_smile:

EDIT:
And it’s shown properly on my Win laptop.

0 Likes

#10

Thanks @eljuno!

I have a nagging suspicion that this is related to the fact that I don’t have a spell check option in Chrome either. I just have no clue what could be causing it. >_<

Edit: Nevermind that, apparently the option looks entirely different in Chrome. But it’s off for me so it’s been a non-issue

0 Likes

#11

Just an update on what I’ve tried:

  • Restarting computer
  • Creating a new browser user
  • Cleaning out all Brave files and re-installning
  • Creating a new account on my computer and trying Brave
  • All versions of Brave: dev, beta, and stable
1 Like

#12

Do you see the difference in the screenshots?

1 Like

#13

also

I had this very same issue but I found that my browser looked different from the video tutorials shown on the various youtube videos. I tried a lot of things that did not work. How I got it to eventually work was doing the following:

  1. type a word incorrectly
  2. block the word
  3. right click on the blocked word
  4. it has several suggestions one being Spell check and ask Google for suggestion
  5. select ask Google for suggestion it will prompt you to add languages. It then adds spell checking. You can also follow the instructions.
    https://productforums.google.com/d/msg/chrome/PPfPm1zbrp0/UbrbktQoAQAJ
1 Like

#14

Yeah, you have an entire “spell check”-section below the languages that I’m missing. You also have a “Brave is displayed in this language”-string that I’m missing. Something just seems so off.

As for your advice, I actually checked out that thread before. But I don’t have an option to “block” a word…

0 Likes

#15

I tried to do “reset all settings to their original defaults” in Settings, but it just got stuck loading for an eternity. Not sure if that’s related.

0 Likes

#16

you can delete your config in profile windows is C:\Users\user\AppData\Local\BraveSoftware

linux ~/.config/Brave

simple delete folder profile and all your settings drop

1 Like

#18

Thank you. I have a Mac, but there’s nothing related to Brave in User/.config. I did go to User/Library/Application Support/Brave-Browser and deleted preferences though. Didn’t make a difference unfortunately.

0 Likes

#19

No difference after enabling this in Chrome and restarting I’m afraid

Edit 1: Apparently ran out of replies for today. Below command didn’t help either unfortunately

Edit 2: Enabling the flag didn’t change anything either

0 Likes

#20

try run with this command

--enable-multilingual-spellchecker

0 Likes

#21

try here

0 Likes

#22

@psynisk,
Before we continue, can you tell me if you’re still encountering this issue after updating to v0.61.51 (released just a bit ago today)? I’ve temporarily lifted your block on posting so that we can get this issue resolved.

1 Like