Microphone not detected on browser

Hello.

I should have reported that earlier, but I am using an older version : 1.25.70. I think any version before 1.28 (included) works fine on my computer . After that version (for instance, the newer version that is out right now). I encounter a problem in which I can hear the others, but they can’t hear me, even if my microphone is unmuted. It’s an issue of the browser or chromium. The microphone will not work in any website. Although works in other browsers such as Firefox. Can you fix it?

I’m using hangouts.google.com

Thank you

Hello @Jaki

could you go to brave://settings/extensions and enable hangout there

and go to brave://settings/content/microphone and make sure that it enabled and no site is blocked there

also could you checked that windows allow the microphone for chrome from your windows settings

hope that help and have a nice day :slight_smile:

Hey.
Thanks for the reply.
I checked and they are enabled.
Still will not work

Thank you

you welcome @Jaki

did you tried while the shield off ?
could you disable all extension and try with and without shield

if both fail then could you try to create new profile and see if it work fine there with and with out the shield

if you use windows system, find the “camera privacy setting” and enable it.

@Jaki,
Apologies but I’m confused – are you saying that you are getting this error when using v1.25.70?

No, sorry for the confusion!
I am using v1.25.70 right now, and it works fine!

The problem occurs in versions after that (or after v1.28 I think). For instance, in the latest version.

I checked all the recommended settings (which all were enabled by default) other people have posted here but still can’t use the microphone (in the beta version, as I can’t have two different versions of Brave. But I did try in the stable Brave version as well, and they can’t hear me/or use the microphone in browser. I am just using beta so I don’t have to install/uninstall all time)

Hello.

Yea, unfortunately I tried all and still nothing. It’s strange that in v1.25.70 it works, but in any version after that won’t. I don’t know if it’s affected by the Windows version or something.

@Jaki,
Can you check and see if you have this setting enable in brave://settings/extensions?

1 Like

Yes, Hangouts is enabled by default. Not the media router, though.

@Jaki,
Just tested this on my end on both macOS and Windows systems and was able to connect to a call on hangouts.google.com and use my mic. While on hangouts.google.com, can you please click the “lock” icon in the address bar and confirm that mic access permission is granted?
image

1 Like

Hey.

Yes they are.
Oh. If it works for you, then it’s not the browser. I don’t understand how different versions can cause this. My Windows 10 version isn’t updated to the latest available. Does that play a role? (I think, it shouldn’t)

@Jaki,
Sorry for the long wait time here.

It could be but I think it’s less likely than some other culprits. Can you please tell me if disabling any extensions you have installed in the browser at this time makes a difference? Also, does the browser pick up your mic on sites/apps other than Google Hangouts?

Hello.

Sorry for the delay.
Happy New Year!
That’s what I think.
Because I can’t uninstall/install brave different versions due to data, I installed a fresh copy of Brave nighty Version 1.36.13 Chromium: 97.0.4692.71 (Official Build) nightly (64-bit).
I tried, but still didn’t work. I also can’t use microphone or camera on other sites.
Permissions are granted.

Thanks!

Thank you for confirming. Will have to dig into this a bit more – thank you for your patience.

@Jaki,
A couple things for you to try – lets use hangouts for the test:

  1. Visit hangouts.google.com and if your mic isn’t detected, try setting the Autoplay permission for the site to Allow. You can do this by clicking the lock icon, then Site settings --> Autoplay --> Allow. Refresh the page and test to see if your microphone now works.
  2. If not, can you try going to lock icon --> Site Settings --> Reset Permissions, refreshing the page, then allowing the site Mic/Camera permissions again and see if this makes any difference?

@Mattches Autoplay it’s already allowed by default
I did reset as well but it still doesn’t work

Try installing Brave beta (which uses a separate profile)

Hey.

I already tried in stable, Beta and Nighty. It happens to all of them

Its a bit late here, but here is the notifications/popups I get when launching Brave Talk, and what it detects.