Microphone Not Detected in Brave Browser on Linux Mint 21.2 (Ubuntu Repo Version)

Description:
I am experiencing an issue with the Brave browser where it fails to detect any microphone on my Linux Mint 21.2 system, despite saying that the microphone permissions are turned on for each. This issue is specific to the Brave version from the Linux Mint Ubuntu repository, as the microphone works correctly in other browsers (including LibreWolf and the Brave Flatpak version) on the same system. This issue is similar to: Brave is not detecting microphone - #11 by justsomeone1 with the only difference being the OS is Linux Mint 21.2 XFCE and not NixOS but oddly enough, both use the deb repository. That previous issue was closed without a solution while waiting for word back from the Linux team. I am to provide more information to try and fix it.

Steps to Reproduce:

  1. Open Brave browser (Version 1.60.118 Chromium: 119.0.6045.163).
  2. Navigate to any website that requires microphone access (e.g., mictests.com).
    3, Attempt to use the microphone.
  3. The webpage displays a message indicating that several microphones are detected, but fails to record any voice input.
  4. The microphone test site reports: “Good news! The microphone checker tool determined that your microphone is working properly.” However, this functionality is not reflected within Brave.
  5. The name of the microphone is detected as “Lync USB Mono” but any microphone will result in the same error.
  6. On websites where microphone permissions were previously granted and functional, the microphone is now detected by Brave but fails to pick up any voice input.
  7. Adjustments to microphone settings and toggles within Brave have been attempted without resolving the issue.

Expected result:
The microphone should be detected and function correctly, as it does in other browsers and the Brave Flatpak version on the same system.

Actual result:
The microphone is not detected by the Brave browser. Websites display an error message regarding microphone access, and testing different microphones shows no response.

Troubleshooting Steps Taken:
Ensured that I am using the most recent version of Brave.
Tried opening Brave in a new private window.
Created a new profile in Brave.
Toggled the ‘Use hardware acceleration when possible’ setting.
Checked for any pending crash reports in brave://crashes.
Turned off Brave Shields.
Temporarily disabled firewalls, VPNs, and antivirus software.
Cleared cookies and site data.
Confirmed that the microphone works in other browsers, including Chrome, LibreWolf, and the Brave Flatpak version.

Additional Information:
Operating System: Linux Mint 21.2 Victoria
Brave Version: 1.60.118 Chromium: 119.0.6045.163 (Official Build) (64-bit)
The microphone is enabled in brave://settings/content/microphone.
No relevant errors found in system logs (dmesg and journalctl).

Logs:
dmesg | grep audio output:

[    5.119726] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.161620] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC233: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    5.161624] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.161626] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    5.161628] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    5.161629] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    5.161630] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x1a
[    5.161631] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    6.518695] usbcore: registered new interface driver snd-usb-audio

journalctl -xe | grep brave output:

user sudo[3395]:    user : TTY=pts/0 ; PWD=/home/user ; USER=root ; COMMAND=/usr/local/bin/apt show brave
user audit[4946]: USER_CMD pid=4946 uid=1000 auid=4294967295 ses=4294967295 subj=unconfined msg='cwd="/home/user" cmd="/opt/brave.com/brave/brave" exe="/usr/bin/sudo" terminal=pts/0 res=success'
user sudo[4946]:    user : TTY=pts/0 ; PWD=/home/user ; USER=root ; COMMAND=/opt/brave.com/brave/brave
user systemd[1059]: Started app-flatpak-com.brave.Browser-5635.scope.
user systemd[1059]: Started app-flatpak-com.brave.Browser-5686.scope.
user systemd[1059]: Started app-flatpak-com.brave.Browser-5894.scope.

lsb_release -a output:

No LSB modules are available.
Distributor ID:	Linuxmint
Description:	Linux Mint 21.2
Release:	21.2
Codename:	victoria

I did a backup of my profile so that I could play around with clean installs as well but haven’t done much with that as I wanted to reach out first:

user@terminal:~$ cd /home/kazin/.config/BraveSoftware/
user@terminal:~/.config/BraveSoftware$ ls
Brave-Browser
user@terminal:~/.config/BraveSoftware$ cp -r Brave-Browser ~/Documents/BraveBackup
user@terminal:~/.config/BraveSoftware$

I am not new to Linux but somewhat new to debugging and ticketing for solutions so I apologise if my format is off. Please let me know what additional information you may require.

1 Like

Hello @Kazin

could you create new linux account and try brave there and see if it work fine or not try the official one first (not the flatpak one)

did you tried to open brave from the command line and see if it report issue on the terminal when you went to the site that require mic

hope one of those help :slight_smile:

Hey @justsomeone1, thank you for the swift reply. I can certainly try the new Linux account, hadn’t thought of that.

I tried following the steps for opening Brave in Terminal for debugging but the steps from the link that I posted which mentioned doing that didn’t seem to work for me and I actually couldn’t find a way to launch it oddly enough. Do you know which commands I should use? Maybe it’s because I was trying with sudo or using the wrong app name?

you welcome @Kazin

the command line is brave-browser-stable --enable-logging --v=1

what is the output of the following command

whereis brave-browser-stable and whereis brave-browser

and do not use sudo with any of the above commands

hope that help and have a nice day :slight_smile:

Ok, so this is what I got:

user@terminal:~$ brave-browser-stable --enable-logging --v=1
[35435:35435:1128/183342.295730:ERROR:policy_logger.cc(157)] :components/enterprise/browser/controller/chrome_browser_cloud_management_controller.cc(163) Cloud management controller initialization aborted as CBCM is not enabled.
tracing_subscriber - init success
[35435:35435:1128/183342.924443:ERROR:sharing_service.cc(221)] Device registration failed with fatal error
^C
user@terminal:~$ brave-browser-stable --enable-logging --v=1
Opening in existing browser session.
user@terminal:~$ [36171:36171:0100/000000.929685:ERROR:zygote_linux.cc(662)] write: Broken pipe (32)
^C
user@terminal:~$ brave-browser-stable --enable-logging --v=1
[36197:36197:1128/183642.761958:ERROR:policy_logger.cc(157)] :components/enterprise/browser/controller/chrome_browser_cloud_management_controller.cc(163) Cloud management controller initialization aborted as CBCM is not enabled.
tracing_subscriber - init success
[36197:36197:1128/183643.385601:ERROR:sharing_service.cc(221)] Device registration failed with fatal error
user@terminal:~$ whereis brave-browser-stable
brave-browser-stable: /usr/bin/brave-browser-stable /usr/share/man/man1/brave-browser-stable.1.gz
user@terminal:~$ whereis brave-browser
brave-browser: /usr/bin/brave-browser /usr/share/man/man1/brave-browser.1.gz

Interestingly enough, a similar issue with someone running Arch Linux is occurring to a user who replied to my GitHub post of this issue that was placed into triage recently: https://github.com/brave/brave-browser/issues/34558 Did the NixOS user ever see his issue corrected? Brave is not detecting microphone - #11 by justsomeone1

you should find the log file here

/home/<username>/.config/BraveSoftware/Brave-Browser/

the log file called chrome_debug.log

by the way did you tried to create new linux user account and did it work fine there or not

Edit: they release new version for brave so try to update first

1 Like

I have a similar issue with an older version of Mint. The mike used to work in Teams in the web client but now will not. All looks good with the settings, but people cannot hear me.
Oddly, it works for a few seconds in talk.brave.com and then fails. It works OK with voice.google.com and with mictests.com and I can also record audio with Audacity etc.

I am running Brave 1.60.125 …

I have seen a similar issue with newer versions of ChromeOS …

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.