Brave is not detecting microphone

Description of the issue:
I cannot access the microphone for any website when using brave. They all work on other browsers on my machine.

How can this issue be reproduced?

  1. Open any website that requires a microphone. E.g.
  2. See webpage’s error message indicating that it cannot find the microphone.

Expected result:
I expected it to find the microphone, which it used to do until I updated to this version (the latest available from my package manager).

Brave Version( check About Brave):
Version 1.46.133 Chromium: 108.0.5359.71 (Official Build) (64-bit)

Additional Information:
Running linux. Specifically NixOS 22.11.

I have tried made sure that the microphone is enabled in brave://settings/content/microphone. I have disabled all my add-ons. I have tried opening a private window. I have refreshed the browser after each attempt. Nothing appears to help.

@iowaguy I have a few questions.

1. What’s the Site Settings look like for there? For example:

Notice in the mix of everything, there’s a portion for Microphone?

2. Does it show the site authorized there?

3. Can you turn off Shields and see if it works? (just in case you have a Shield setting preventing it)

4. Might not accomplish anything, but mind either doing Guest Window or Create a new profile and testing on that?

Hello @iowaguy

i am wandering how did you install brave on NixOS ?

Sorry for the slow reply. Thanks for the suggestsions. I tried them all, but none seemed to fix it. They are addressed individually below.

  1. What’s the Site Settings look like for there?

Does it show the site authorized there?

Yes, it is authorized

Can you turn off Shields and see if it works?

Turning off Shields had no impact.

Might not accomplish anything, but mind either doing Guest Window or Create a new profile and testing on that?

Still seeing the issue in a guest window.

I put brave in my nix configuration in the system packages field.

@Mattches you have any ideas?

For this website, are you able to get to the point where you have to click Test my microphone or does the site just infinitely load the Detecting mic phase?

On my end, I had to turn Brave Shields off in order for the site to detect my mic — seems like Shields wants to block the site from detecting the mic. After turning Shields down, the test worked as expected.

I never see a Test my microphone button. It just eventually says Click here to try forcibly start the microphone (see below)

But when I click that button, I get the following error

Are there any sort of application logs I can look at?

I’m wondering if this is a Linux specific issue — I’ve reached out to our Linux folks to test and see if they can reproduce the issue. Hope to have more information soon.

I’m also curious as to whether or not any other sites show this same behavior. For example, if you were to join an Google meet/Zoom/any video conferencing service are you able to use your mic for it?

Thank you, @Mattches.

Yes, I am seeing this with all sites. I discovered the problem trying to access google meet, but have since also seen the problem with zoom.

Hello @iowaguy

currently brave version is
Version 1.46.153 Chromium: 108.0.5359.128 (Official Build) (64-bit)

while your post said you using version
Version 1.46.133 Chromium: 108.0.5359.71 (Official Build) (64-bit)

so does update fix the issue by the way i think the most updated version you will get for nix would be 1.46.144 based on that link

and i see they use the deb package from brave repository

so till the linux team replay if you interested to debug it you can run brave in debug mode and check the log maybe it help

this for mac but and for chrome but you at least know the correct flag you want

and here the command line for brave

I’m also curious what package you used to install Brave? Did you use the install instructions from our website or did you install via snap or some other method?

@Mattches nixOS is not derivative of Ubuntu or Debian and it’s not listed on the website nixos use it’s own package manage called Nix package manager. it’s main goal to offer atomic /reliable upgrade

but i was surprised when i notice it use deb package when it used brave

@iowaguy is there any option in the system that control the access of microphone to certain app like block mic/cam for certain app

and have a nice day all of you :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.