Metamask not being able to connect with other apps such as opensea, dydx, etc

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:
Hi, so I am trying to connect to Dydx and other web3 apps using metamask on brave. I am able to unlock Metamask but the popups that ask to connect with apps no longer appear and when I try to click ‘connect’ with these outside apps nothing happens.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
I had tried to install brave wallet too but I deactivated because I prefer to use MetaMask.

Actual Result (gifs and screenshots are welcome!):
Metamask just is, nothing happens, no connection is established and I can’t connect to Dapps

Expected result:
Be able to connect to Dapps using Metamask.
Reproduces how often:
It used to work now it does not.
Operating System and Brave Version(See the About Brave page in the main menu):
Mac OS Catalina 10.15 Intel Macbook Mid 2012.
Additional Information:

@Inspect100,
This is a known issue that the team is currently addressing:


You should see this issue resolved in the next major browser update.

Ok, so I found a temporary fix for this issue. Once the error is encountered, deactivate the wallet extension inside brave, then restart the brave browser and now try to connect to Dapps or web3 using metamask and it should work now.

It worked for me on windows and Mac.

1 Like