Metamask extension not working since I signed up for Brace wallet

NOTICE: Please only post Brave Wallet/Crypto wallet inquiries in this category – please go here for Brave Rewards support

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
Metamask won’t connect to any Dapps. Metamask working in Chrome. I have removed and reinstalled extension twice. Keplr is connecting fine.
I have already selected ‘None’ in Brave>Setting>Default Ethereum wallet.

Are you using the (new) Brave Wallet or the (old) Crypto wallets implementation?

How can this issue be reproduced?

Brave Version (check About Brave): 1.47.171

Additional Information:

Can you please try setting your ethereum wallet to ‘prefer extensions’ and also delete any other ethereum wallets that are on your extensions and try again.

let me know if that works, Thanks.

1 Like

Tried that just now then restarted Brave. Still can’t connect. Works fine on Chrome, which I would really hate to switch back to.

Could you try creating a new user profile , setting up Metamask again along with Brave Wallet and seeing does that work ?

Thanks @hub that seems to have done the trick.

1 Like