Can't connect with MetaMask or Xdefi anymore

All of a sudden i can’t connect my MetaMask or Xdefi wallet.

Some additional info:

  1. I have no issues using Keplr or Phantom wallets.
  2. I have tried different Default cryptocurrency wallet settings and nothing works.

How to fix this issue?

Hi @guleko, what Brave version and OS are you on? What is your default chain set to? Thanks in advance for any info.

Hi Steeven,

  1. Brave v1.40.113
  2. Monterey 12.3.1
  3. You mean on Metamask? Ethereum

What dApp are you attempting to connect to? Are you receiving any errors when attempting a connection?


Whatever i try to connect to, it either shows that it is attempting to connect or nothing happens.

Thank you for this information.

I would attempt a restart of the device and a relaunch of the browser first.

If that does not resolve the matter, please try the following:

  • try disabling all extensions
  • try accessing in a new private window
  • try creating a new test profile
  • try Brave Beta and/or Nightly versions

Thank you

Using Brave Beta worked.

But you guys should figure out what the issue is with the regular version.

Really annoying to not be able to use certain extension all of a sudden.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.