Message "Your connection is not private"

I now get the message “Your connection is not private” on a multitude of websites.
Another possibility is that the website loads but images don’t load (such as stackoverflow), because these images are hosted on another site that is deemed unsafe.
Additionally some websites cannot be reached at all unless I type “thisisunsafe”. To reach your website brave.com, e.g., I had to switch to Firefox, because I was unable to do anything with Brave.

I use Brave [Version 1.31.91 Chromium: 95.0.4638.69 (Official Build) (x86_64)] on mac osx El Capitan. I have already set my chrome://flags/#allow-insecure-localhost to “enable”.

Is there anything else I can do to circumvent this annoying behaviour. It is getting to the point that Brave is becoming unusable.

Thank you for your feedback.