"Your connection is not private" error accessing Gmail, Google, Youtube

Can not access websites Gmail, Google, Youtube, etc. Facebook works.

  1. Start Brave
  2. go to gmail.com
  3. the gmail inbox should load (or login prompt should appear)

Instead I got error " Your connection is not private" and can not proceed to any of Gmail, Google, Youtube.

Many other pages work well.

Happens every time.

I am running Linux Manjaro. I have the same version (up to date) at work and as well as on my home computer. The funny thing is that it runs well at home, but not at work. Same versions of the OS, Brave.

I have tried to clean all the caches, remove the ~/.config/BraveSoftware, disable all shields - no difference.

Update: It works when I run the brave as root with sudo

from console:
[28944:28958:0528/131057.141993:ERROR:cert_verify_proc_nss.cc(969)] CERT_PKIXVerifyCert for gmail.com failed err=-8172
[28944:28949:0528/131057.142276:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -202
[28944:28949:0528/131057.290288:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -202
[28944:28949:0528/131105.368029:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -202

Thanks for reaching out!
I imagine that this is due to the network/security policy that your work has set in place. If that was the case though, you’d expect to see the same behavior for all sites visited – not just Google based sites as you mentioned.
You may want to try clearing all accounts.google.com site data.

  1. Launch Brave, open the main menu
  2. Navigate Settings --> Advanced --> Privacy/Security --> Site Settings --> View all site data
  3. Use the search bar on this page to find all entires for accounts.google.com and delete them
  4. Close/relaunch Brave and try to access/visit these sites again.

Thanks @Mattches. The network/security policy is very unlikely, because it works as root. I have cleared all data - this does not help.

I suspect that this has something to do with certificate handling…

1 Like

Problem solved by deleting the ~/.pki folder