[macOS] CMD + ` (AKA CMD + ~) is a global OS setting that cycles open browser windows. It works fine on Firefox and Chrome. On Brave, it seems to switch between recently used tabs, or even URLs in the same tab

Description of the issue:

CMD+` (AKA CMD+~ AKA CMD+backtick AKA CMD+tilde) should cycle through open browser windows, per browser. Brave does not respect this global setting.

How can this issue be reproduced?

  1. Open 2 Brave windows, with at least 2 tabs on one
  2. Press CMD+`
  3. Watch Brave cycle the tabs or even URLs under some circumstances, rather than the windows.

Expected result:
Brave should respect the system setting and cycle through the open windows, only.

Brave Version( check About Brave):
Version 1.57.64 Chromium: 116.0.5845.188 (Official Build) (arm64)

Additional Information:
In my case, I also use pinned tabs on one window (including Gmail, which does the URL issue), which may be relevant.

Similar to this issue: ⌘` (command-backtick) "Move focus to next window" not working on Mac Monterey

@mbinder I’m wondering if this could be related to https://github.com/brave/brave-browser/issues/31770

For the moment, can you try the steps below and advise if things seem to work fine?

  1. Launch Brave, go to brave://flags
  2. Search for a flag called #brave-comands
  3. Set the value to Disabled and relaunch the browser

Actually, looks like it’s working as intended now. My fix: I unpinned all my pinned browser tabs, then repinned them. I’m now unable to reproduce the issue. Strange! This plagued me for months, browser restarts and all, but it never occurred to me that the issue might be pinned tabs. I’ll come back if it recurs.

1 Like

Okay, I marked your last comment as solved for now. We’ll reopen if you come back to share you’re experiencing issues again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.