Leaving private mode is buggy

Description of the issue:
Instead of going back to normal, I just get back to an empty private tab. Fiddling around a little eventually got me back. Then I had 14 empty tabs open. Don’t know if private or not.

How can this issue be reproduced?

  1. Enable option to keep private tabs open (don’t know if relevant)
  2. Enter private mode and open some tabs
  3. Close all tabs and try to leave private mode

Expected result:
Going back to normal mode

Brave Version( check About Brave):
1.57 (

Mobile Device details
iPhone SE 2

Additional Information:
This thing really needs a proper bug tracker.

I just want to confirm, how did you try to go back to normal?

The reason I’m asking is because on other devices, just closing your last Private tab will exit. But on iPhone, you have to hit Private again to deselect it and go back to normal mode. And when it switches back to normal, it opens with whatever open tabs you had.

I just tried replicating your issue on my iPhone and it didn’t happen. Everything seemed to work flawlessly. So just wanting to see if you’re doing something different or something else is up.

Assuming you were doing as I mentioned above, then could you provide info on what version of iOS you’re using

That’s exactly what I did, with the result described above. Unfortunately it seems to be one of those bugs that can’t always be reproduced. It happened to me twice during normal use but now that I tried to make a screen capture of it, I can’t seem to make it happen. :pleading_face: Im running on latest iOS 16.6.1. So all I can offer at the moment is to make a video if it happens again, which can only proof that I didn’t make this up but nothing else, so just checking the code in question would be the smarter thing to do. Or maybe I could send some debug logs if you can tell me how to obtain them.

@Bachsau instead of intruding on someone else’s topic, let’s get back over here. The last thing you said is you can’t seem to make it happen again. So it was sounding as if resolved. If you’re still having the issue, it helps to share that. And if you can get a recording of what you’re experiencing, that’s even better.

Bugs don’t tend to resolve themselves. Please understand that if everything were OK, it wouldn’t have happened even once. Being unable to reproduce a bug only means that we don’t know the exact circumtances that trigger it. I didn’t want to intrude on this person’s topic. I was sure that he just came across another instance of exactly this bug and I wanted to support him, but I tend to overestimate people. Tapping again the same button that was used to enter private mode in the first place seems like the most intuitive thing for me. He said the only way for him to exit private mode was to close and restart the app and I believed him. Even though I managed to get out somehow without that, the initial behaviour of the button was exactly like that for me: It just didn’t work.

The most promising way to tackle this would be for a developer to go through the code handling leaving of private mode on iOS and try too find out why this happens. In the end it is your product, and we aren’t your beta testers. You had this bug reported, so maybe you should consider that there’s something wrong. No offence meant, but this is really frustrating. Almost every company receiving bug reports try to handle it this way, selling users for dumb and requesting evidence. If there’s some sort of debug mode I can enable that will produce some sort of log, I will happily do that, but I’m not paid for this. This is your product. It should be in your own interesst to make it as bug-free as possible and be thankful for every report. If things become unusable, people will just move on to another product. Thanks for reading.

Oh, not at all. I was so used to how it worked on Desktop and all. It actually confused me at first. It took a lot of toying around before I thought to hit the button again. Each person has different ways of thinking.

Hence why I communicate the way I do. They either would have clarified if meant something different or it helped. In the case of that topic, you’ll see they marked it as a solution and the button was the only thing they didn’t notice.

Those two things are the contradictory issue. It must be able to be replicated in order for a developer to be able to look through code and figure it out. If nobody knows what’s happening or the trigger, you can’t do anything about it.

When you have thousands, if not millions, of people using the app/program and only one person has an issue, think about how difficult it would be to figure out what’s going on. In fact, the issue could be something from outside the browser causing an issue.

There’s a lot of moving parts with code and many ways it can go wrong. The code itself could be perfect but the person’s device or something on their device is the fault.

Again, just saying to have to get it replicated. There are a lot of things developers are working on. They can’t put it all on hold to go through millions of lines of code to try to figure out why one person might have had an issue. When more people have problems, they can get better information but it also means it’s easier to replicate and they can find better.

They are, as am I. At the same time, communication has to occur and people to understand that this isn’t just as simple as you make it sound. Information is gathered from people like you who are reporting possible issues and then that is used to try to replicate it and figure out what’s going on. Then they can narrow down where to look and roll out fixes.

I noticed this problem too but only on my debug builds sometimes. Not on the app store build.
Recording this behavior would be helpful for us

1 Like

It happened again. Here are two videos of bugs affecting private browsing mode.

In the first video I entered private browsing by holding a suspicios link and chosing “Open in private tab”. I then tried to leave private mode, which did not work. Tapping the button seemingly disabled it (the lighter background removed), but Brave did stay in private mode. Notice how the local/synchronised buttons appear. You can also see the normal tabs for the blink of an eye. I was able to leave by tapping the button after manually closing all tabs. This doesn’t always work. I also was able to reproduce this bug when playing around, but still can’t tell what exactly triggers it.


The second video was made shortly after and is mostly reproducible. You open one normal tab, then another. From this second tab you chose to open a link in a private tab. From there you open tab overview, switch back to normal mode, and WITHOUT leaving the popup, close the tab from which you opened the private tab (notice it’s not the one with the blue frame) and re-enable private mode by tapping the button, all without leaving the popup. Then tap “Done”. You end up in private mode UI but with the remaining non-private tab active.


Even without looking at the code, I’m almost sure this happens because the app has a unified stack of tabs recently active, and that stack isn’t always kept in sync with UI switches. It might be the cause for both bugs. In the second case, since private mode was active when tab overview was opened and it was still active when it was closed, the app didn’t see the need to make changes to the active tab. It missed that closing the normal tab changed the stack and brought another normal tab on top. My guess is that both bugs are somehow related to what closing a tab does to the last-active-tab-stack. Please make sure that your “keep private tabs” setting is active while testing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.