How to escape from Private Browsing?

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

Opened a private tab, and now can’t access the 72 non-private tabs I had open.

How can this issue be reproduced?

  1. Open some tabs normally.
  2. Click and hold on an URL.
  3. Select “Open in private window” from pop-up.
  4. Break down in tears after hours of searching for a way to return to the original 72 open tabs.

Expected result:
I expected to be able to view a site privately and then close it to return to the 72 non-private tabs I had open.

Brave Version( check About Brave):

Version 1.30.1 (21.8.17.19)

Mobile Device details
iPad 7th gen (MW772LL/A) running iPad OS 14.7.1

Additional Information:
Seriously, folks: I only wanted to visit ONE site privately and then return to what I was doing (which was browsing normally, not privately). I’ve dug through all my menus as well as your private browsing “help,” which doesn’t contain much of anything helpful. I hadn’t expected to be trapped in private browsing forever. How can I return to my 72 open tabs? Please tell me before I’m done ripping my hair out. Thanks!

Tap on ‘tabs’ button, then the private button in bottom left should be highlighted, you can tap on it to go back to regular mode

1 Like

Sorry if you found it confusing

Michal, the screenshot did the trick! I hadn’t realized that the orange button meant that it was enabled, so it didn’t dawn on me to tap it. It worked! I’m now out of private browsing! Thanks a million! :kiss:

Except … I now have exactly ONE tab, for a new window. All 72 of my “normal” tabs are gone. :cold_sweat:

To the Brave folks: this shouldn’t happen. As we switch from normal to private browsing and back again, NONE of our tabs should go away. This makes me frightened to use private browsing again, knowing that you’re going to throw away all of my work by closing all of my open tabs.

You may call this a “feature,” but it appears to me to be a bug, and a serious one at that. Data loss bugs are the worst (and I know you know this); that horrible feeling when our stomachs drop when we realize we’ve lost all our work is like no other. :face_vomiting:

Please add this to your list of things to fix ASAP. Thanks! I love being able to browse privately in theory, but in practice, it clearly doesn’t work.

Again, Michal, thanks ever so much for helping me out; I was frantic and my nose was sore from all the crying in frustration. You’re my hero! :kissing_heart:

Binky

I work on the Brave iOS app btw, glad I managed to help you exit the private mode :slight_smile:

Your normal tabs should not be gone, they should always be restored even when you close this private mode.

Private tabs are gone when you exit private mode, but normal tabs should always stay there. There is a chance it’s some kind of bug on our side, we will investigate it.

You can try killing your app(swipe up from the app switcher) then open it again, sometimes it can help with lost tabs.

Soon we add a new feature that allows people to quickly bookmark all currently opened tabs, this will help if there is worry of losing data

1 Like

Hi, Michal:

I didn’t realize you’re on the Brave dev team; I’d thought you were just a very useful community member. I lucked out reaching you right away!

As soon as I saw all my tabs were gone, the first thing I did was to quit and restart, hoping all my missing tabs would be restored, but no such luck. :cold_sweat:

I just did some experiments, opening several tabs, then entering Private mode the same way that caused the problem (tapping and holding a link and then selecting “Open in new Private tab”) in an attempt to recreate the problem, but nope: when I left Private mode, my tabs were restored this time, each time I tried, exactly the way I expect them to be.

I’m thinking that perhaps there’s a number of tabs that causes the problem. (Remember that I’d had 72 “normal” tabs.)

I’ll keep banging on the problem, see whether I can reliably reproduce the problem, and get back to you with the results.

If, in the meantime, your team looks at the problem, trying with a LOT of normal tabs, then perhaps we might be able to nail down the problem. I certainly don’t want that happening again, as I tend to work with a LOT of open tabs (often more than a hundred).

By the way, I’m quite sure (though not 100% sure) that I’d more than one instance of Brave running, and that the other instances closed along with my tabs.

By this, I mean that I had more than one Brave window open, each with multiple tabs. I frequently have more than one Brave or Safari instance going, as another app will open a new instance rather than opening a new tab in an existing instance.

I hope you know what I mean by this, as I’m trying to explain it as clearly as I can.

Oh! I took a screenshot demonstrating three “instances” of Safari (I actually have five instances, but then don’t all show up in the screenshot); this should make it clear what I’m describing. I hope that now you understand what I mean and that this helps inspire you to know where to look in the code for the problem.

Thanks very much, and I’ll be back when I have more info. Meanwhile, have a good weekend!

Binky

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.