Issues Downloading Torrent

I am having an issue downloading torrent files. On the racingfor.me site, I try to download a torrent file and I get a blank page as shown in the attached pic. On other sites, I have zero issues. I get the normal option to download the torrent. Would this be a particular issue from the site I’m trying to download from or is there an error or fix I can make?

I am running
Version 1.25.70 Chromium: 91.0.4472.77 (Official Build) (64-bit). Thank you for your assistance!

@StreetDreamer83,
Thanks for reaching out.
Can you test and see if turning Shields off for the site changes the behavior?

I tried that and got the same result.

@StreetDreamer83,
So it’s hard for me to diagnose this or test it because I do not have an account for the site. After trying to download the torrent file, can you right-click on the page and pick Inspect from the context menu, then click on the Console tab in the resulting window, then share a screenshot of any output you see here?

Untitled

I would just like to reiterate that I appreciate your assistance.

1 Like

@StreetDreamer83,
Hmmm that is strange…Can you try testing the behavior in a private window as well? I’ve reached out to our web compatibility team as well for additional input.

I tried and got this error page.

@StreetDreamer83,
Are you trying to download using the built-in WebTorrent extension? Or do you have a different torrent client you’re wanting to use?

I’m wanting to use the built-in extension.

Well now I’m even more confused. When you are on the site, are you downloading the torrent file or using a magnet link?

I am attempting to download the torrent file.

Can you check and see if using a magnet link works? Can you also tell me if you have any other downloaded/third party extensions enabled at this time?

Unfortunately, the site doesn’t offer magnet links unless there is a way I can do so that I’m unaware of.

@StreetDreamer83,
Can you try creating a new temp. browser profile and see if you’re able to download torrents when using the new profile? When performing this test, ensure that you close any/all other Brave instances/windows, such that you only have one window open, using the new profile.

It did the same thing. Something that I’ve noticed though is when I first attempt to download the torrent, I am able to download the torrent file. If I try it again though, I go back to what I originally posted.

This is when you’re using the new profile?

It did it when I used the new profile and my regular one but it only does it the first time I attempt to download the torrent.

@StreetDreamer83,
I’ve reached out the team for some additional input here as I’m really not sure what the issue would be.

I am curious if you get this same behavior if you were to use other websites to download torrent files?

I have zero issues when using other torrent sites. This site is the only one where I have this problem.

1 Like

Thank you for confirming. Let me reach out to some web compatibility folks and see if we can find out what’s going on.