Issue with Meta-mask and Brave - Seeking Help

Heys guys I have an issue and I’d love to hear if any wizards out there have a solution.

I recently installed Brave as a friend of mine mentioned how Crypto friendly and privacy geared they are.

I installed metamask and moved a sizeable amount of crypto into the wallet.

Added a hardware device to further secure it and now it will not move any crypto to any page or swap on any DEX.

To further add insult to injury I cannot recover the wallet on another browser nor move the crypto from my meta mask on brave to any other wallet, it just freezes and times out.

Upon asking around a lot someone said Brave stopped using meta mask, I have no idea if this is true and I didn’t see any warning or documentation of this fact. Pretty Sure Meta mask is the biggest web3 wallet around so this perplexes me.

I’m open to any ideas or solutions you may have or if anyone knows if this will be fixed anytime soon.

Thanks

Rich

Any ideas people?

Really any ideas would be awesome as it appears nobody has any idea.

You are using MetaMask extension right? Not the fork Brave used of Metamask for some period by default.

Please confirm that MetaMask is listed in brave://extensions and share the extension ID.

If the MetaMask extension is freezing then that seems like something to troubleshoot with MetaMask. Just be careful and don’t share your recovery phrase with anyone. There are a lot of phishers out there, especially if you use the word MetaMask on Twitter.

If you have your recovery phrase you could try restoring it in another wallet like Brave wallet which is found at brave://wallet.

You may also want to check your Brave version if you’re having trouble 1.35.100 is the latest.

Hi Brian

Thanks for jumping in on this.

It seems that this cannot be recovered with the recovery phrase as it was secured by my hardware wallet through metamask.

I downloaded the extension through the brave browser and the other day was notified brave discontinued the metamask extension.

I downloaded a strange looking and dogey looking version of metamask in an attempt to fix this, I found it on a blog article on github.

nothing has seemed to work so far…

Metamask - MetaMask
10.9.2
An Ethereum Wallet in your Browser

ID: nkbihfbeogaeaoehlefnkodbefgpgknn

I tried recovering my wallet on chrome but the address wasn’t there when selecting from available wallet5 addresses that my hardware device had to offer.

If I update the metamask version there may not be a way to recover it due to the nature of how the trezor connects with meta mask.

Chrome has worked fine and had no issues when using meta mask and my trezor so I’m super confused.

Any ideas from this Brian?

was notified brave discontinued the metamask extension.

That is not accurate. You can still use MetaMask in Brave no problem.
We did stop offering Crypto Wallets extension (fork of MetaMask) in Brave because our new wallet is much better though.

nkbihfbeogaeaoehlefnkodbefgpgknn is indeed MetaMask’s extension ID though and not our old fork’s extension ID.

You should get the same addresses though in our native built-in wallet at brave://wallet as in MetaMask.

It seems like you’re trying to get MetaMask to work though so you’ll have to check with MetaMask about how their extension works. Thanks!

Hi Brian

I went in through the brave wallet and the wallet id was not importable.

When I went to import it in the Brave wallet the id didn’t show on the list, I went through thousands of them but strangely the same ID didn’t appear.

The meta mask extension works great on Chrome but for some strange reason not on Brave it just freezes every time I use it and fails to send anything.

Meaning the crypto is stuck in that metamask wallet on Brave and cannot be sent to any other wallet or used to connect with any web 3 page or DEX.

Do you have a checklist of things to try just to be certain I’ve tried everything before writing off the crypto and continuing with my other wallets on Chrome?

Thanks

Rich

Could you confirm your Brave version?

Hey Brian, I’ve looked under settings and it says.

V 1.35.101

You could try going to brave://settings/wallet and setting the default wallet to None. But there is no code that Brave has specific to MetaMask that would make it work differently than in Chrome. I.e. a new profile on Brave would just as likely work as a new profile on Chrome.

Do you see anything abnormal in the hamburger menu top right then in More tools then in Task Manager? You can also go to chrome://extensions, turn on developer mode and click on the link to inspect the background page. Any errors in that console?

I think it is most likely some kind of MetaMask bug that your state led to.

Not sure if this helps but it still freezes and refuses to connect with any web3 pages and still won’t send anything from Metamask.

Nobody at Metamask has been able to help so guessing that’s that. :frowning:

Literally heard nothing back.


move anything from the Metamask

Seems like MetaMask is pegging the CPU to 100% too. Could you try sending that console message tot he MetaMask team?

I’d be happy to do a Brave Talk meeting next week with you too so you could share your screen and we could troubleshoot. Please email me at brian@brave.com if you’re willing to troubleshoot with available times. If so, please also include a link to this thread.

Hi Brian

I have emailed you off my work email.

And sent the images to Metamask support.

Thanks, talk to you Wednesday!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.