Issue with add TXT to Godaddy records dns - Website add Creator

I had the Godaddy tech support even look at this and try and input it in. Tried many different ways But it keeps saying my channel cannot be verified Some help would greatly be appreciated. I have tried coping and pasting txt in records main domain (not subdomain). Type * TXT
Host *
TXT Value *
brave-ledger-verification=+++++3477 does not seem to verify

Thank you for reaching out to us! We have a short video tutorial that covers both site verification methods:

Try following along and see if you can retrace your steps and see where you went wrong. If you are still unable to do this, you may want to try the alternative File upload verification method instead. There is a text version of both available as well if you’d prefer:

The host name should be @ or

Still not working. Only able to perform step B DNS entry with godaddy.

Tried both but still not working thanks for trying

TXT @ brave-ledger-verification=*****958 1 Hour

TXT brave-ledger-verification=****3477 1 Hour

You’re going to have to be more specific and with what it is you’ve already tried if you’re still having trouble. Where in the process are you getting stuck? Also, when answering, please remember not to share personal emails or any account related information publicly on the forum.

Godaddy does not offer the Https file method of verification so I have to edit DNS in records. I followed step by step the instructions by Brave. I go to

DNS Management


I click Add button

It gives me option Type: I Select – TXT — It gives me option Host: I have tried @ and ----- It gives me option for Data value I put the value a copy and paste from Brave: " brave-ledger-verification=****3477" I try to verify and it says Retry Verification

Your website,, was not verified because the token in your TXT records is incorrect. Please make sure the token in your DNS entry is correct. I called Godaddy support and they tried to follow the instructions as well with no luck.

Hi, I am having the same issue, except instead of GoDaddy I’m using Hover.
I’ve added a TXT record to our DNS, using the “@” for “Hostname” as that’s required for Hover.

I believe I’ve given it enough time to propagate and it still hasn’t.
We are currently using Cloudflare for the SSL cert on this site. Would that possibly be blocking the verification?

The error message is:

Your website,, was not verified because we could not find TXT records in your domain’s DNS records. Please make sure you have entered the token in your DNS records:

Also, I’m very passionate about Brave and BAT right now. I’m a software developer and am happy to be of any assistance in helping send logs or deep-dive this issue. I’d love to see Brave and BAT take over, and willing to donate time or help out, starting with this issue.

My issue turned out that I had partially started the process once before and had to delete all previous attempts. It finally worked _ Cannot remember if I used the @ or Starship420com (my website) as the host that made it work

Thanks for the advice. It’s definitely not working for me still. It’s been 4 days, this is the only TXT record I have in there. I’ve tried adding my domain and the @, and in Hover, the domain automatically changes to @. I’ve done a lot of DNS for AWS work for my job. I believe something is legitimately wrong with the DNS verification here.
Could be because we’re using Cloudflare? or because we have a weird TLD? (.studio)
Either way, hopefully this will help in investigating this issue.

This topic was automatically closed after 30 days. New replies are no longer allowed.