Issue linking Uphold wallet for verification

I am using Version 1.47.186 Chromium: 109.0.5414.119

My Uphold wallet suddenly disconnected from the brave wallet, and it says I am not verified. I don’t know what triggered this.

I have tried to link it again, but now get an error message that I have limited Uphold account functionality.

This is not true, as I have checked in the uphold wallet and it shows me as verified.


How can I fix this and get my brave wallet verified and connected with Uphold again?

You should follow steps mentioned at

Also, wanted to point out that your Brave version is a bit old. The latest one is 1.48.158

Thanks for all this detail. Maybe the problem was caused by turning on 2FA.
I wish there was a way to do this for free, as every transaction is costing me $0.99.
I traded some ETH to BAT, but I did not get the verification screens, it went through ok (minus the fee). I tried to connect the Brave wallet again, but I still get the same error and it will not connect.

Oops. I guess you didn’t read it well. We just had to pretend to do a withdrawal and not actually do one. What the OP meant was that when you try to withdraw, you’ll get that verify window.
Anyway, best if you raise a ticket with Uphold at

But the withdrawal is confirmed after the verification, how is this “pretending”?

What the OP meant was that when you click on withdraw that, time you get that verify your identity window.

Sure, and as soon as the verification is approved, the withdrawal will automatically go through. So it will cost me $0.99 and I have to withdraw something.

According to people who have done this, you don’t need to complete the transaction.

1 Like

OK. I was worried to do this, because I thought that it would automatically continue the transaction after the selfie. I did not realize that after the selfie the screen will go back to the confirmation button, and I can then cancel the transaction from there.
I have successfully done the selfie, and cancelled the transaction. I have tried the Brave wallet verifying and it has worked! Issue resolved!! :partying_face:
Thanks everyone for your help and patience.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.