Issue: ERR HTTP2 NADEQUATE TRANSPORT SECURITY

If i try to go to some websites the “Error ERR_HTTP2_INADEQUATE_TRANSPORT_SECURITY” occure.

You can try it with https://stadt-bremerhaven.de/

The issue occures every time.

I use this versions:

Version 1.26.77 Chromium: 91.0.4472.164 (Offizieller Build) (64-Bit)

Windows 10 Pro Build: 19042.1083

How can i solve the Problem? With Firefox it works fine.

Works fine for me! Idk what’s your problem. Does it still say the error?

Unfortunately yes.

Try opening the website in a private window with all extensions disabled.

If the issue isn’t reproducible in a private window with all extensions disabled, you might want to clear your cookies and cache, something IBM suggest regarding the issue: https://www.ibm.com/support/pages/errhttp2inadequatetransportsecurity-error-message-google-chrome-browser-when-connecting-portal-https.

To clear cookies and cache, type brave://settings/clearBrowserData in the address bar.

Unfortunately it doesn’t help.
Tried it with a fresh Chrome installation and it end up with the same problem.

I found a solution for Firefox:

"If you’re trying to browse to a website and you’re getting the error NS_ERROR_NET_INADEQUATE_SECURITY in Firefox and you’re not an administrator of the server, you can disable HTTP/2 in Firefox.

Open Firefox and type about:config in the address bar
Click on I Accept The Risk
Search for network.http.spdy.enabled.http2
Change the value to False
Restart your browser "

Is there a same solution for Brave?

Its working fine for me.

Maybe open the website and Turn off your Shields from the Lion Icon near the Search bar.

Or Clear the cache as @Rethanis suggested above.

Tried to clear the cache and what ItzMeRajat suggested. Unfortunately both doesn’t help.

Do you use a VPN by any chance?

No not at all. The Site works fine with Firefox but not with Brave and Chrome. Of course I can use Firefox, just triing to find out what the Problem is…

Try the Change Chrome launch parameters part of the guide below while using the --disable-http2 parameter.

2 Likes

This is the Solution:
Just add in the shortcut:
-use-spdy=off
-disable-http2

Thanks Rethanis!

1 Like